Closed Bug 1824210 Opened 1 year ago Closed 1 year ago

`Favorite Folders` cannot be moved away from bottom of folder list where it's hard to see

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 112
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: m_cathcart, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Supernova3p])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/111.0.0.0 Safari/537.36 Edg/111.0.1661.44

Steps to reproduce:

Favorite folders used to be at the top of the folder list/view. Since the Supernova beta FAVORITES is at the bottom and as far as I can see, unmovable.

While the Supernova UI objective is to remove clutter etc. I will still want Favorites and to be displayed at the top of folders list.

Expected results:

favorites should either be placed at the top automatically or have a set option to display it there.

Hey Mark, I have good news for you:
Both on Beta 112.0b3 (64 bits) and on 113.0a1 (2023-03-23) (64-bit), Win10, this is still possible in the same way as in 102.
Here's how:

  1. Click on the Folder pane options meatball menu next to + New Message
  2. Check (tick) Favorite Folders
  3. Uncheck all other folder view modes (All Folders etc.) so that only Favorite Folders remains (now shown at the top)
  4. Now check (tick) any other folder view modes which you need in the order in which you want them displayed under Favorite Folders.

This works because any mode which you check will always be added in the last position, so you just need to start out right and add them in the right order. I think that's good enough as we don't expect users to change their folder pane every day ;-)

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID
Summary: Thuderbrid Favorites at bottom of folder list, not visible → `Favorite Folders` cannot be moved away from bottom of folder list where it's hard to see
Whiteboard: [Supernova][support]
Attached image Main Layout.jpg

Thanks for taking time to respond. I'd been through all the windows and settings trying to do this. Somehow I assume I have a messed-up laylout but have been using Thunderbird for less than a year and this is kinda how my layout has been and woprked. I watched the video on Supernova and I just don't have a Folder pane options and New Message or a meatball menu. Is there some way I can reset the UI or change the setting via a menu?

I'm running 112.0b3 (64-bit on Windows 11.

(In reply to Mark Cathcart from comment #3)

Thanks for taking time to respond. I just don't have a Folder pane options and New Message or a meatball menu. Is there some way I can reset the UI or change the setting via a menu?

Pls try:

  • View > Folders > Folder Pane Header - that should bring back the thing on top of folder pane.

But even without showing the folder pane header, you can always show/hide folder view modes directly from menu:

  • View > Folders > All/Unified/etc. (per my procedure of comment 1).

Let us know if both of these work for you.

Thank you. Yes, Folder Pane Header worked. I apologize for taking your time.

I'd be more comfortable in cases like this to use WORKSFORME rather than INVALID. If we use INVALID in such cases then users might look at a bug and think "oh, this can't be done", when in fact it can.

INVALID per https://wiki.mozilla.org/BMO/UserGuide/BugStatuses#Resolutions is literally "this isn't a bug", and that is the case here.

But IMO a more nuanced interpretation is appropriate, the most common case being "this is caused by code that isn't ours" or a situation that breaks our code that otherwise works fine.

I like WORKSFORME for "this actually works but user misunderstood how this works", and the more common, works in a newer version. Perhaps this bug is an example where a user hint in the UI is needed about ordering?

Resolution: INVALID → WORKSFORME
Whiteboard: [Supernova][support] → [Supernova3p]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: