Closed Bug 1824287 Opened 1 year ago Closed 1 year ago

Firefox now thinks GTK indicates user prefers reduced motion, even though user config hasn't changed

Categories

(Core :: Widget: Gtk, defect, P3)

defect

Tracking

()

RESOLVED INVALID

People

(Reporter: eros_uk, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Ubuntu 22.10 Wayland, 113.0a1 (2023-03-23) (64-bit)

As enquired last Monday in #nightly:mozilla.org, hamburger menu has lost its sideways sliding animation (jumps to other pages).

The issue may be limited to Wayland.

Note: prefers-reduced-motion is not present in about:config

The Bugbug bot thinks this bug should belong to the 'Core::Widget: Gtk' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core

Does the issue go away when you set ui.prefersReducedMotion to 0 in about:config? (You may have to add the preference if it doesn't already exist).

Can you use mozregression tool to find broken commit?
https://fedoraproject.org/wiki/How_to_debug_Firefox_problems#Use_Mozregression_tool
Thanks.

Flags: needinfo?(eros_uk)
Priority: -- → P3

(In reply to Gregory Pappas [:gregp] from comment #2)

Does the issue go away when you set ui.prefersReducedMotion to 0 in about:config? (You may have to add the preference if it doesn't already exist).

Yes

(In reply to Martin Stránský [:stransky] (ni? me) from comment #3)

Can you use mozregression tool to find broken commit?
https://fedoraproject.org/wiki/How_to_debug_Firefox_problems#Use_Mozregression_tool
Thanks.

Sadly, mozregression GUI doesn't work on system and I am not good with the CLI.

Flags: needinfo?(eros_uk)

mozregression doesn't have GUI, you can use command line tool. Just run on terminal as the how-to says, it will run Firefox. You can use it and then switch back to terminal and type good/bad according to test results.

Flags: needinfo?(eros_uk)

(In reply to Martin Stránský [:stransky] (ni? me) from comment #5)

mozregression doesn't have GUI, you can use command line tool. Just run on terminal as the how-to says, it will run Firefox. You can use it and then switch back to terminal and type good/bad according to test results.

https://mozilla.github.io/mozregression/quickstart.html

GUI

The easiest way to use mozregression (at least on Windows) is via the GUI. This youtube video by Pascal Chevrel describes how to install and use it:

https://mozilla.github.io/mozregression/install.html

mozregression-gui

For the graphical interface, we provide a simple installation process:

  • Windows: Download the latest mozregression-gui.exe file from the github releases. Once the file is downloaded double-click on it and follow the installation process. Some anti-virus programs falsely claim that mozregression is a virus, you can ignore this warning: see bug 1647533.
  • Mac: Download the latest mozregression-gui.dmg file from the github releases. Once the file is downloaded, click on it and drag the “mozregression GUI” icon to “Applications”. Note that on recent versions of MacOS X you will need to override the setting that disallows installing applications from unidentified developers since at present we do not sign mozregression (see bug 1366570).
  • Linux: Download the gzipped tarball of mozregression-gui corresponding to your version of Ubuntu from the github releases. Once the file is downloaded, extract it and run the mozregression-gui file in the mozregression-gui directory. Example:
tar xf mozregression-gui-ubuntu-22.04.tar.gz
mozregression-gui/mozregression-gui

See Also: Bug 1749215

Flags: needinfo?(eros_uk)

I think this is by design as a result of indicating "prefers reduced motion".

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID

(In reply to :Gijs (he/him) from comment #7)

I think this is by design as a result of indicating "prefers reduced motion".

ui.prefersReducedMotion is NOT present in about:config.

Flags: needinfo?(gijskruitbosch+bugs)

(In reply to erosman from comment #8)

(In reply to :Gijs (he/him) from comment #7)

I think this is by design as a result of indicating "prefers reduced motion".

ui.prefersReducedMotion is NOT present in about:config.

Sorry, that's not really how I read comment #2 / comment 4.

It sounds like on your system Firefox thinks the OS is indicating you don't want animations. Looking quickly, it would seem this should be based on "notify::gtk-enable-animations", but there might be more to it. Maybe the gtk folks can clarify.

But presumably this also means that e.g. page load indicators on tabs show the hourglass rather than the dot moving side-to-side?

Status: RESOLVED → REOPENED
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(eros_uk)
Resolution: INVALID → ---
Summary: No Animation in Hamburger Menu → GTK thinks user prefers reduced motion

ui.prefersReducedMotion is only present in about:config when explicitly created and will overwrite whatever info we get from the platform (GTK). It's absence doesn't indicate that prefers-reduced-motion isn't enabled based on GTK.

HOw can it be (In reply to :Gijs (he/him) from comment #9)

Sorry, that's not really how I read comment #2 / comment 4.

It sounds like on your system Firefox thinks the OS is indicating you don't want animations. Looking quickly, it would seem this should be based on "notify::gtk-enable-animations", but there might be more to it. Maybe the gtk folks can clarify.

But presumably this also means that e.g. page load indicators on tabs show the hourglass rather than the dot moving side-to-side?

Nothing was set by me, so whatever the issue, it is not user config.

Tab indeed shows hourglass rather than the dot moving side-to-side.

The issue started around 6-7 days ago. When I asked in #nightly:mozilla.org, others didn't seem to have the issue. It can be a Wayland related issue (e.g. recent 1823336, 1823249).

Flags: needinfo?(eros_uk)

OK. You're sure that this hasn't been enabled the whole time and you just started noticing it when we started applying the preference to the hamburger menu?

If this is indeed a recent regression then a window/timeline would be very helpful. I don't see anything obvious in hg log widget/gtk. Maybe Emilio has ideas.

Summary: GTK thinks user prefers reduced motion → Firefox now thinks GTK indicates user prefers reduced motion, even though user config hasn't changed

(In reply to :Gijs (he/him) from comment #12)

OK. You're sure that this hasn't been enabled the whole time and you just started noticing it when we started applying the preference to the hamburger menu?

Of course ... I posted to #nightly:mozilla.org 1-2 days (IIRC) after it stopped animating. I use hamburger menu very regularly, often many times a day.

Could there be a hidden config for it (for Wayland)?
Is there a way to verify?

I think what Gijs is asking is whether you're sure that the prefers-reduced-motion key wasn't set. If you do mozregression --launch 111 and run the following in the console, what does it print?

window.matchMedia('(prefers-reduced-motion)').matches
Flags: needinfo?(eros_uk)

Do you have "Enable animations" turned off in the accessibility section of the gnome settings?

window.matchMedia('(prefers-reduced-motion)').matches

Result: true

Do you have "Enable animations" turned off in the accessibility section of the gnome settings?

It is OFF but AFAIK I had not changed it. 🤔

Changing it to ON, changes window.matchMedia('(prefers-reduced-motion)').matches to false and the hamburger menu animation is back.

Has Nightly always been reading window.matchMedia('(prefers-reduced-motion)').matches?
If so, then this bug can be closed.

Flags: needinfo?(eros_uk)

Yes, I think this is working as intended. Afaict that setting should be on by default...

If it repros on a clean ubuntu install we should probably reevaluate it.

Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → INVALID

After some observation .....

With "Enable animations" turned ON the behaviour of Gnome 43.0 changes noticeably (especially windows minimise, maximise). I am positive that:

  • it has been OFF since I installed Ubuntu 21.10
  • Hamburger menu had slide animation until 6-7 days ago

Furthermore, I tested now on Firefox 111.0.1 (64-bit) with "Enable animations" turned OFF and the Hamburger menu slides as it has been.

The conclusion would be that something has changed in Nightly. It could be that previously Firefox didn't apply '(prefers-reduced-motion)' and started to apply it a few days ago.

Flags: needinfo?(emilio)

Well Firefox started honoring prefers-reduced-motion in the hamburger menu in bug 984589 recently, that is expected.

Flags: needinfo?(emilio)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: