Closed Bug 1824374 Opened 1 year ago Closed 7 months ago

implement popover target attributes

Categories

(Core :: DOM: Core & HTML, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
114 Branch
Tracking Status
firefox114 --- fixed

People

(Reporter: surkov, Assigned: surkov)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Depends on: 1826793

(In reply to alexander :surkov (:asurkov) from comment #0)

bug 1826793 is filed

implemented as part of bug 1821732

Assignee: nobody → surkov.alexander
Attachment #9328563 - Attachment description: WIP: Bug 1824374 - implement popover activation behavior → Bug 1824374 - implement popover activation behavior, r?emilio
Status: NEW → ASSIGNED
Pushed by surkov.alexander@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d030d5dc991d
implement popover activation behavior, r=emilio
Keywords: leave-open
Backout by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/33db288f32f4
Backed out changeset d030d5dc991d for causing popover related wpt failures.

Could you link please which tests failed specifically? It's weird but I had no issues locally.

Flags: needinfo?(csabou)

here's an example of failures, https://treeherder.mozilla.org/logviewer?job_id=412576527&repo=autoland&lineNumber=33684

apparently I was updating wpt tests on out of date build, since the log mentions :popover-open which is not yet implemented (was backed out recently iirc). I will try to update to trunk, update wpt tests expectations and reland.

Flags: needinfo?(surkov.alexander)
Pushed by surkov.alexander@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/241b4b54e654
implement popover activation behavior, r=emilio
Pushed by surkov.alexander@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/525d1491fa5b
implement popover activation behavior, r=emilio
Flags: needinfo?(surkov.alexander)
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Regressions: 1868740
Target Milestone: --- → 114 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: