If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Javascript error with layers loading page

RESOLVED FIXED

Status

()

Core
HTML: Parser
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: Ricardo Salgado, Assigned: harishd)

Tracking

Other Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Bug is with 1.2 builds only; site loads fine with trunk builds], URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126

In the page at http://www.vizzavi.pt/, with Mozilla release 1.2, a Javascript
error occurs: "There seems to be a error with this layer". The error did not
occur in previous versions. Tried 1.1

Reproducible: Always

Steps to Reproduce:
1. Just go to http://www.vizzavi.pt/
Actual Results:  
Javascript error occurs: "There seems to be a error with this layer".

Expected Results:  
Load the page correctly as in previous versions.
Server seems to be down.

Comment 2

15 years ago
I can reproduce this on 1.2 final. It works as expected the trunk from a few
days ago (both Win98). Bug 182500 may (or indeed may not) explain it, but it
seems to share many features with the bugs marked as dependencies (javascript
related, work on trunk, does not work on 1.2). Of course if it also broken on a
newer trunk build then it's not related to 182500.
This is 1.2-branch only.  See bug 182500.
Depends on: 182500
Version: Trunk → Other Branch

Comment 4

15 years ago
Confirming based on two separate reports above. Reassigning to Parser
for parity with bug 182500 -
Assignee: rogerl → harishd
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → Parser
Ever confirmed: true
QA Contact: pschwartau → moied
Whiteboard: [Bug is with 1.2 builds only; site loads fine with trunk builds]
I have tested that this bug was an instance of bug 182500 / bug 182253 based on
comparison of two Linux builds compiled with gcc 3.2.  This bug was present in
the 1.2 release and was the only bug fixed in the 1.2.1 release (and the reason
for the 1.2.1 release).

Marking this bug as fixed since it should be fixed in the 1.2.1 release.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.