Closed Bug 1825993 Opened 1 year ago Closed 1 year ago

Junk column is always reported to screen reader users no matter if the junk message list column is showing or not

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 113
defect

Tracking

(thunderbird_esr102 unaffected, thunderbird114? fixed)

RESOLVED FIXED
115 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird114 ? fixed

People

(Reporter: pvagner, Assigned: aleca)

References

(Blocks 1 open bug)

Details

(Keywords: access, Whiteboard: [Supernova3p])

Attachments

(1 file)

Steps to reproduce:

This is a follow up to the bug 1813492.

  • Make sure junk column is not showing
  • Use F6 or shift+F6 to focus a message list
  • Use up or down arrow keys to navigate

Actual results:

When message thunderbird has identified as spam receives the focus the word spam is communicated to screen reader users eventhough junk column is not showing.

Expected results:

Eventhough the message has been identified as junk, user has deliberatelly hidden the junk column and it should not be reported.

Keywords: access
OS: Unspecified → All
Hardware: Unspecified → All
See Also: → 1813492
Whiteboard: [Supernova]

Perhaps by design. Not harmful.

Blocks: sn-msglist
Severity: -- → S4

Well visual presentation of junk column can be turned off and I think this should not be an exception.
Although until bug 1822048 is solved having this switched off is good for me if I wish to have it enabled. So ideally it would be nice to try fixing these 2 issues together.

Whiteboard: [Supernova] → [Supernova3p]

The issue is due to the spam notification that gets triggered from the message pane, is not coming from the message list.
If the spam column is hidden in the message list also the spam buttons are hidden, so there's no way that's part of the accessible label of the message row.
I can confirm that that comes from the message pane showing the notification. That also works like that in 102, right?
I think this is correct since a spam message needs to be communicated properly when is opened, even if the user has the junk column not enabled.
Not communicating the junk status of a junk message is pretty bad from a security point of view.

I'm inclined to WONTFIX this, unless I'm missing something.

No longer blocks: sn-msglist

(In reply to Alessandro Castellani [:aleca] from comment #3)

The issue is due to the spam notification that gets triggered from the message pane, is not coming from the message list.

No. It is not the notification that it is spam. The notice "Spam" can be found in the message list.

To reproduce this with JAWS, please follow these steps:

Steps to Reproduce

  • Install JAWS and start it.
  • Start Thunderbird and focus on a junk message in the message list using the arrow keys.
  • Now press JAWS key+Windows key+Numpad Minus to turn on the so called script utility mode. The script utility mode, previously named Home Row mode, contains many keys to obtain information useful when developing scripts.
  • Press F10 until you hear "Name". This key switches between the different MSAA objects.
  • Now press F9 to hear the current "Name" attribute of the currently selected item.

Result

For example, you get the following output:

"Spam, Sender, Subject, Time".

Now there is a way to show or hide the spam column in the message list. If you are looking for avoiding working more on this, can you please try to explain to me what is different for a typical thunderbird user with this column showing and not showing?
Is the spam status forced to non screen reader users in some way?
Jaws is just one way on how to verify this information but I think the spam is part of the accessible name on all platforms.

Let me explain it once more.
When the spam column is visible we are getting spam announced two times. The word spam correctly respects the column ordering however there is a new text saying message marked as junk at the begining of the accessible name text.
When the spam column is not visible the spam is announced as if it was visible, it even respects the ordering configured while the column was visible earlier and the extra text is gone.

If you can't accept our arguments then I suggest at least looking at it so fixing this will avoid clutter and possible support burden as having it like this will create questions why in the default setup screen reader users are getting two announcements about the fact selected message is flagged as spam.
Should I describe it in more details with example content or is it clearer now please?

Flags: needinfo?(alessandro)

Perhaps bug 1822048 also contributes to this. I am unsure where the text message marked as junk comes from.

Hey, sorry, I didn't mean to come off as dismissive, I really thought that that "Spam" announcement was coming from the message pane notification.

I definitely accept your arguments and I appreciate a lot both of your insights and suggestions. We wouldn't be able to make a good product without you, so please keep doing what you're doing.

I'm honestly baffled because I can't find where the heck this "spam" string comes from.
It's not in the accessible name of the element, so there must be a flag or an attribute attached to spam messages that is read by JAWS.
I'm still investigating this, but definitely fixing it is important!

Blocks: sn-msglist
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(alessandro)

Oh thank you for acknowledging. I didn't want to sound rude or otherwise inappropriate. Excuse me if you did not liked the tone of my comment.

Thanks and greetings

Peter

No no, all good, your tone was appropriate and your message correct.
I can totally understand your frustration, and I can relate since this is driving me crazy because I have no idea where that "spam" string is coming from.
I'll find the issue and fix it!

See Also: → 1834397
Assignee: nobody → alessandro
Status: NEW → ASSIGNED
Duplicate of this bug: 1834397
Target Milestone: --- → 115 Branch

Pushed by solange@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/ffc956786298
Do not add accessible strings for hidden columns in the thread pane. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Comment on attachment 9335578 [details]
Bug 1825993 - Do not add accessible strings for hidden columns in the thread pane. r=darktrojan

[Triage Comment]
Approved for beta

Attachment #9335578 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: