Changing the complete frameset by means of target="_parent" donesn't work any more

RESOLVED FIXED

Status

()

--
major
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: arippel, Assigned: harishd)

Tracking

Other Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021126

There is this widespread javascript source for navigation, which I think
originated from Dreamweaver. I toggles Gifs, when you move over the images and has
 a wrapped anchor-element around them. When you click on a button the target is
_parent, so the complete frameset is replaced. This works for all browsers on
any plattform til Mozilla 1.1.
Now Mozilla 1.2 isn't able to resolve the sources for the images and shows the
brokens links. I don't know if this is a correct implementation or a bug, or the
original Dreamweaver?-source is kind of crude?   

Reproducible: Always

Steps to Reproduce:
1. go to http://www.vcrp.de
2. click e-Learning on the left navigation bar
3. you see the broken image links

Actual Results:  
you see the broken image links

Expected Results:  
Mozilla can also resolve the image sources

The is tested on Linux and Windows 2000

Comment 1

16 years ago
i see this with 1.2 release, but not on 1.3a.
Adding dependency to parser error meta bug 182500
Assignee: frame → harishd
Status: UNCONFIRMED → NEW
Component: Layout: HTML Frames → Parser
Depends on: 182500
Ever confirmed: true
QA Contact: amar → moied
I have tested that this bug was an instance of bug 182500 / bug 182253 based on
comparison of two Linux builds compiled with gcc 3.2.  This bug was present in
the 1.2 release and was the only bug fixed in the 1.2.1 release (and the reason
for the 1.2.1 release).

Marking this bug as fixed since it should be fixed in the 1.2.1 release.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Version: Trunk → Other Branch
You need to log in before you can comment on or make changes to this bug.