Closed Bug 1827225 Opened 11 months ago Closed 5 months ago

Hide popovers when making another element fullscreen

Categories

(Core :: DOM: Core & HTML, enhancement)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1831057

People

(Reporter: jarhar, Assigned: zsun)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/113.0.0.0 Safari/537.36

Steps to reproduce:

Call showPopover on an element with the popover attribute, then call requestFullscreen on another element.

Actual results:

The popover element stayed open.

Expected results:

Then popover element should have been closed.

Spec PR: https://github.com/whatwg/fullscreen/pull/204
WPTs:
https://wpt.fyi/results/html/semantics/popovers/popover-top-layer-combinations.html
https://wpt.fyi/results/html/semantics/popovers/popover-top-layer-interactions.html

The Bugbug bot thinks this bug should belong to the 'Core::DOM: Core & HTML' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → DOM: Core & HTML
Product: Firefox → Core

It seems like not hiding popovers would be pretty annoying to end users, but since the spec PR hasn't been merged, I can't set a severity yet.

The whole feature is still under development, I'd move this to Enhancement.

Type: defect → enhancement
Depends on: popover
Assignee: nobody → zsun
Blocks: popover
Depends on: 1831057, 1832837
No longer depends on: popover
Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Duplicate of bug: 1831057
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.