Closed Bug 1828281 Opened 10 months ago Closed 10 months ago

Links to ID attributes that are inside a details tag are not found

Categories

(Core :: DOM: Core & HTML, defect)

Firefox 112
x86_64
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1724299

People

(Reporter: jim, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/112.0.0.0 Safari/537.36

Steps to reproduce:

Browse to a local link identified using the id attribute that is inside of a details block does not work.
For the attached file, browse to TbAxiStreamFifo_TestCases_log_MWE.html#default_TbStream_RandomFifo1

Actual results:

It does not find the local link and it browses from the top of the file

Expected results:

It should open the details block (rotate the triangle) and show the details surrounding the link target - at least this is what both Chrome and EDGE do.

Component: Untriaged → DOM: Core & HTML
OS: Unspecified → Windows 10
Product: Firefox → Core
Hardware: Unspecified → x86_64
Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Duplicate of bug: 1724299
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.