Closed Bug 1829343 Opened 1 year ago Closed 1 year ago

Toolbar buttons of standalone message window don't work

Categories

(Thunderbird :: Message Reader UI, defect, P1)

Thunderbird 113

Tracking

(thunderbird_esr102 unaffected, thunderbird113 wontfix, thunderbird114+ fixed)

RESOLVED FIXED
115 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird113 --- wontfix
thunderbird114 + fixed

People

(Reporter: d.mcdivitt, Assigned: darktrojan)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Supernova3p])

Attachments

(2 files)

Attached image pic.jpg

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/112.0.0.0 Safari/537.36

Steps to reproduce:

I updated to 113.0b3 (64-bit) from 110.0b4. In bug 1822607 I reported the same issue, it was marked as a duplicate and the duplicate marked resolved. I have made comments to the original bug and no one read them. After updating to 113.0b3 I made a picture showing the same issue as my previous bug report. I click on the previous, next, and delete buttons at the top of a message window and they do not work. I must now roll back to version 110.0b4 again. Yes I donate to Mozilla for Thunderbird.

Actual results:

The buttons do not do anything.

Expected results:

The buttons should do what they're supposed to do.

This is for the "old customization" I think. Try customizing using the unified toolbar on top. The buttons work there.

Component: Untriaged → Add-Ons: Extensions API
Keywords: regression
Whiteboard: [Supernova]

Confirmed.

The three mentioned buttons, which can be added through the old customization method, do not work. Not in the mail-bar3 toolbar (still used in the messageWindow.xhtml), nor in the mail-menubar menubar.

I doubt this is an WebExtension API issue, as there is no add-on involved at all. Moving it to Message Reader UI, is that the correct component?

Status: UNCONFIRMED → NEW
Component: Add-Ons: Extensions API → Message Reader UI
Ever confirmed: true
Flags: needinfo?(alessandro)
Whiteboard: [Supernova] → [Supernova3p]
Blocks: tb-new-3pane
Summary: Toolbar buttons on pop up message window do not work → Toolbar buttons on menu bar or Mail Toolbar (from old toolbar customization) do not work on standalone message window

I don't know about an "old customization method". Just now I upgraded to 113.0b3. I double-clicked a message to open it in a window. The menu bar items in the message window did not work. I did customize for the menu bar. I deleted the buttons and added again. They still do not work. I am rolling back to 110.0b4 again. When I see the beta version has incremented in help/about I will try again.

(In reply to Magnus Melin [:mkmelin] from comment #1)

This is for the "old customization" I think. Try customizing using the unified toolbar on top. The buttons work there.

This is incorrect as the user shared a screenshot showing the standalone window and not the main application window.
The standalone window still has the old toolbar and customization since we're not removing that for 115.

This is definitely a regression, probably some methods that need to be hooked to the new currentAbout3Pane.

Geoff, do you have time to take a look at this?

Flags: needinfo?(alessandro) → needinfo?(geoff)

Hello. I tried 113.0b5 and the issue still remains. What beta version might I expect this to be fixed?

(In reply to David McDivitt from comment #5)

Hello. I tried 113.0b5 and the issue still remains. What beta version might I expect this to be fixed?

Not possible to say

Severity: -- → S2
Priority: -- → P1
Summary: Toolbar buttons on menu bar or Mail Toolbar (from old toolbar customization) do not work on standalone message window → Enable Unified Toolbar in standalone message window [was pre-supernova Mail Toolbar does not work]

I'm changing the title here since what was written is incorrect.
We're not applying the unified toolbar to the standalone message window for 115.
If buttons don't work in the standalone message window toolbar it means that something needs to be hooked properly to the new abot3Pane, as I wrote in comment 4.

Summary: Enable Unified Toolbar in standalone message window [was pre-supernova Mail Toolbar does not work] → Toolbar buttons of standalone message window don't work
Assignee: nobody → geoff
Status: NEW → ASSIGNED
Flags: needinfo?(geoff)
Target Milestone: --- → 115 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/47a2c3a1f14f
Fix toolbar buttons for the message window. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Attachment #9333020 - Flags: approval-comm-beta?

Comment on attachment 9333020 [details]
Bug 1829343 - Fix toolbar buttons for the message window. r=aleca

[Triage Comment]
Approved for beta

Attachment #9333020 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: