Closed Bug 18304 Opened 20 years ago Closed 20 years ago

NS_ERROR_UNEXPECTED from js when using proxy

Categories

(Core :: Networking, defect, P3)

x86
Windows 98
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: mystiq, Assigned: travis)

References

Details

(Whiteboard: [PDT-])

I've got Wingate 3.0.5 on my NT box, and Mozilla 5 absolutely refuses to work
on any of the client machines. It'll work (or worked once, it's a p133 and it
doesnt like apprunner :-) on the NT box, but only because it's directly
connected. Mozilla 4 works with no proxy, but Wingate still has some problems
as the version im using doesnt support NAT and some other nifty stuff.
Assignee: leger → gagan
Component: Browser-General → Necko
Moving to Necko.

I'm not sure if this bug report has enough detail to be reproducable.
Need more info please.
All i can think of to add, Mozilla 5 has proxy problems. Straight from
apprunner:

JavaScript Error: uncaught exception: [Exception... "Component returned failure
code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIBrowserInstance.loadUrl]" nsresult:
"0x8000ffff (NS_ERROR_UNEXPECTED)" location: "JS frame :: file:///D|/PROGRAM
FILES/NETSCAPE GECKO/BIN/chrome/navigator/content/default/navigator.js ::
BrowserLoadURL :: line 864" data: no]

If interested, my exact setup:
Server: Wingate 3.0.5, NT 4 SP 5, mozilla 5 works fine

Clients: Wingate 3.0.5 W98, mozilla 5 refuses to download a page, but yes, it
will open a page and display it, showing it has troubles going through the
proxy.

A game, (Age of Empires 2), also has troubles connecting to sites. Wingate has
troubles with UDP, ICMP, and another protocol which i forget, which is probably
the reason this's happening.

Wingate's homepage, http://www.wingate.com
Status: NEW → ASSIGNED
Summary: denial of service :) → [BETA] NS_ERROR_UNEXPECTED from js when using proxy
Target Milestone: M14
Summary was: "denial of service :)"
Changed to: "[BETA] NS_ERROR_UNEXPECTED from js when using proxy"

Seems like the unhandled exception needs to be addressed in the webshell
cleanup.
Resetting QA contact from leger.
Blocks: 20400
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
Keywords: beta1
pdt - why is this beta1, what is the user impact?
Adding [NEED INFO] to Status Summary.
Whiteboard: [NEED INFO]
per warren's comments this seems like a webshell issue. ->travis.
Assignee: gagan → travis
Status: ASSIGNED → NEW
Summary: [BETA] NS_ERROR_UNEXPECTED from js when using proxy → NS_ERROR_UNEXPECTED from js when using proxy
I'm not sure why this is a beta1 blocker either.  Move to M15 until someone can
convince Travis and I otherwise.
Target Milestone: M14 → M15
We agree; it's not beta. PDT-.
Whiteboard: [NEED INFO] → [PDT-]
Warren, what was your info?  How is this a webshell bug?  What needs to change?
This looks like it may be the same issue as bug 26493, "Install crashes, browser 
doesn't browse web" [using wingate], also marked PDT- and beta1, but M14, 
ASSIGNED to rpotts@netscape.com

mystiq@optonline.net, can you get a current build of mozilla (since 2000-02-18) 
to work with Wingate? Bug 23709 may have been the culprit, but there's no way
to tell without testing.
Downloaded new version of Mozilla and the proxy software. Mozilla is happy and
not crashing.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
verified by original reported
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.