Install crashes, browser doesn't browse web {Wingate}

CLOSED WORKSFORME

Status

()

Core
Networking
P3
critical
CLOSED WORKSFORME
19 years ago
6 years ago

People

(Reporter: davidelihu, Assigned: rpotts (gone))

Tracking

({crash})

Trunk
x86
Windows 98
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

(Reporter)

Description

19 years ago
I have found 2 bugs with the new browser.

1.  I can't browse the web in the browser of seakmonkey, neither in the 
viewer.exe.  When I launch the browser, no page loads.  I browse the web 
through a wingate server, and I am a client.  In the earlier builds, I could 
browse the web.  Wingate 3.0 is not supposed to be run through a proxy server.

2.  The bug above was found earlier.  Now I can't even run mozilla.  When I 
download the installer for win98 (any build including m13, and nightlies), it 
freezes (illegal op in necko.dll) upon beginning to install the first file 
(right after "preparing smartupdate").  I spoke to someone on a chat room, and 
they said to try the fullcircle, which would return the bug to developers.  
However, I can't even run that.  When I launch mozilla.exe from fullcircle, I 
get an illegal operation in the dos prompt.

Thank you.

Comment 1

19 years ago
This all seems reminiscent of bug 22298, "Mozilla delays, then crashes in use 
with WinGate Gateway Client".

davidelihu@netscape.net, do you know if the Wingate Client installs a DLL which 
replaces or chains itself in with the Microsoft Win98 Winsock DLL? (It isn't 
called just winsock.dll on Win98, IIRC)

Also, you could try the .zip version of M13 or a nightly. There is no install
process, it just keeps all of the files needed in one directory tree, so 
whether or not one of those worked for you would help narrow down whether this
is a networking or installer problem.

Finally, the exact message that appears in the DOS window may be relevant to
tracking this problem down. Couls you please record it here?

Finally, have you installed any other software lately (between 1. and 2.)
that required you to reboot before using it?

Thanks!
Assignee: leger → gagan
Severity: blocker → critical
Component: Browser-General → Networking
Keywords: crash
QA Contact: cbegle → tever
(Reporter)

Comment 2

19 years ago
this bug is present on every wingate client I have.  no, i can't run just the 
zips.  when I run mozilla.exe, i get an illegal operation.  Regarding the 
quesiton whether wingate alters your winsock, I think it may.  however, in the 
recent builds i have encountered this problem.  

I have found a bug of a similar nature.  I downloaded mozilla on a computer at a 
school that ran a proxy server.  When I configure the program for a proxy, and 
run it, and enter my user id and password, the window keeps popping up.  it 
sometimes works, and then the browser goes crazy.

Comment 3

19 years ago
Thanks for replying. Based on what you've said, it looks like Mozilla doesn't
like the state of your system as it is now, meaning that it is assuming that
it can call certain functions at particular locations in system files where 
they are not to be found on your system. Others with Win98 are not having
these problems.

Leaving in the "Networking" Component in case what Mozilla isn't liking
is in parts of your system that WinGate changed.

The issue with the repeated proxy authentication is a known issue covered
already by another open bug.

I hope you are able to use Mozilla again soon. Please, try to report only one
problem per bug report, though. The Bug-writing Guidelines at 
http://www.mozilla.org/quality/bug-writing-guidelines.html are quite useful.

Comment 4

19 years ago
Rick: do you have any experience with the WinGate stuff? 
Assignee: gagan → rpotts
(Assignee)

Comment 5

19 years ago
Nope...  I tried to connect to http://wingate.deerfield.com/download to check it
out, but the server was down :-(

It sounds like yet another 'somebody whacked winsock and now we crash...' bug
:-)  I've got a Win98 machine now, so I can try tracking this one down if you'd
like...

-- rick
(Assignee)

Comment 6

19 years ago
Oh joy...  I just made it to the WinGate homepage and it looks like WinGate
requires Winsock 2 for Win95.  Guess what?  This will cause bug #23709 to be
aggrevated...

So, for Win95 configurations, WinGate will *not* work until we resolve bug #23709.

Since this bug was reported on Win98, it looks like something else is going
wrong there too... :-(

Updated

19 years ago
Keywords: beta1
Target Milestone: M14

Comment 7

19 years ago
how common is wingate?  Is there a work around?

Comment 8

19 years ago
Marking PDT- due to marketing factors; we can release note this.
Whiteboard: [PDT-]
(Reporter)

Comment 9

19 years ago
Note to rpotts@netscape.com - the wingate client I have is running on windows 
95.  maybe that is what is causing the problem.  don't know.  not very 
experienced with wingate.
(Assignee)

Comment 10

19 years ago
hey david,
If you are running on a Win95 box using WinGate, then this "could" be a dup of 
bug #23709 (believe it or not).  The crux of 23709 is that mozilla will crash on 
Win95 if WinSock2 is installed.  Since WinGate requires winsock2 then this 
"could" be the problem.

-- rick

Comment 11

19 years ago
Bug 18304, "NS_ERROR_UNEXPECTED from js when using proxy", and 
bug 22298, "Mozilla delays, then crashes in use with WinGate Gateway Client",
appear to be about the same issue. 

In 18304, the Wingate clients were Win98; in 22298, either WinNT or Win2000.
Either way, it looks likely that bug 23709 is not the whole problem.

Updated

19 years ago
Blocks: 30247

Comment 12

19 years ago
1. It is sometimes possible to get the Seamonkey M14 running with WinGate 3.0.5 
(WinNT 4, SP6a), provided that the Wingate client is enabled after Seamonkey 
has loaded. (Sorry - can't reliably reproduce this).
2. Installer works for me in M14 - didn't in M13.  Perhaps split this topic 
accordingly if I'm not the only one?

Comment 13

19 years ago
Correction: to make it work with WinGate 3.0.5 -
1 Disable the WinGate client
2 Load Seamonkey and tell it to use the WG server as a proxy on port 80
3 Re-enable the client. Seamonkey, already in memory, will not respond to the 
state change in the client.
Messy, but functional.

Comment 14

19 years ago
*** Bug 22298 has been marked as a duplicate of this bug. ***

Comment 15

19 years ago
The reporter of bug 22298 confirms both that the workaround proposed by
john@gn.apc.org works, and that it is necessary. 

john@gn.apc.org, thanks for identifying the workaround. Adding relnote keyword.
Keywords: relnote
Summary: Install crashes, browser doesn't browse web → Install crashes, browser doesn't browse web {Wingate}

Comment 16

19 years ago
Got it:

In Wingate client's Control Panel app, choose the 'Applications' tab and add 
mozilla.exe with the property 'Local Access only'.  THIS IS NOT A FIX, but it 
will allow Seamonkey to start without further modifications to Wingate client, 
provided the WG server is set in Seamonkley at port 80.

Still kinda sucks, but makes M14 stable and useable.  Aythangew.

Comment 17

19 years ago
Background information:

Not mentioned in this thread so far is the fact that the Wingate 3 client 
replaces Windows 9x/NT's winsock.dll and/or associated files in order to 
function in a pseudo-transparent fashion.  Suspect that a) this is bound to be 
the root of the problem and b) this probably renders this bug dependent of 
another (sorry- don't have the time right now to identify which one(s).)

Comment 18

18 years ago
*** Bug 33392 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Target Milestone: M14 → M15

Comment 19

18 years ago
It works for me last I tried (Win98).
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 20

18 years ago
Request this re-opened - no evidence provided to close it (and it sure as hell 
hasn't changed recently).  Any chance that ruslan@netscape.com can be a little 
more - erm - *detailed*?  This one has about 6 sides to it

Comment 21

18 years ago
is there anyone running wingate / win98 who could check if there is still a 
problem here
(Reporter)

Comment 22

18 years ago
The problem is solved
Status: RESOLVED → CLOSED

Comment 23

17 years ago
-relnote, fixed.
Keywords: relnote

Comment 24

6 years ago
this is a very old thread, however just to clear things up.

WinGate client does not replace any winsock.dll,  It is a Winsock 2 Layered Service Provider, which is a DLL registered with winsock, and which is loaded by winsock when an application loads it.

LSPs are only supported in Winsock 2, which is why the WinGate client requires Winsock 2.
You need to log in before you can comment on or make changes to this bug.