resubmission of form upon lack of acknowledgement of receipt

RESOLVED WORKSFORME

Status

()

Core
HTML: Form Submission
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Ran, Assigned: Alexandru Savulov)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; OneDisc.com, Inc.; MSN; .NET CLR 1.0.3705)
Build Identifier: [multiple builds]

Users of LiveJournal (http://www.livejournal.com/, an online journalling site) 
using Mozilla to update their journals (at 
http://www.livejournal.com/update.bml or http://www.livejournal.com/update.bml?
mode=full) have reported that Mozilla will often post their entries multiple 
times.

The problem appears to be this: LiveJournal's servers are continually under 
very high load, so that LiveJournal is not always able to return 
acknowledgement of receipt when the post-entry form is submitted, even when it 
is submitted properly. It appears that when LiveJournal does not acknowledge 
the form submission, Mozilla resubmits the form, sometimes repeatedly. This 
does not appear to be the behavior of other browsers (such as Internet 
Explorer).

Reproducible: Sometimes

Steps to Reproduce:
I imagine the following steps would work, if they are possible, though I've not 
been able to try them:

1. Set up a server in such a way that it does not acknowledge form submissions.
2. Create a form on this server that, when submitted, sends you a "form" e-mail.
3. Submit this form in Mozilla.
Actual Results:  
You will receive the form e-mail infinitely many times (or as many times as 
Mozilla submits the form before you close the browser).

Expected Results:  
I cannot say what Mozilla /should/ do, but the behavior of Internet Explorer is 
to submit the form only once. In the case of LiveJournal, the latter is 
certainly much preferable; and, in general, I can think of no circumstance 
where Mozilla's current behavior would be preferable to simply informing the 
user that the form submission was not acknowledged, and suggesting that they 
try again.

I will report additional information as I procure it.

Comment 1

16 years ago
i've seen something like that happen when i add attachments in bugzilla reports.
The first time was 2002-04-16 in bug 119328.  Mozilla just kept spinning.

I thought it hadn't uploaded yet, but since it took it's while I happened to
reload the bug in another tab. And saw 3 copies of the attachment!

Had to hit STOP to abort the mischievous uploads. Same thing happened again
around a week ago.

Comment 2

16 years ago
What exactly is happening? Is the page changing when the submit button is
clicked, or the throbber starts to spin? Is there a repeated post dialog that
pops up? Is the submit button clicked repeatedly? Is the page reloaded repeatedly?

Comment 3

16 years ago
personally i clicked once, then sat back and waited. I thought it took
mysteriously long to add one pic, so i opened a new tab - opened the bug there,
and saw that the attachment i had gotten no confirmation about had already been
uploaded three times. I then activated the tab the attachment form was in and
hit STOP button, to avoid further messing up the bug. On an occation a week aga
the same happened, but with a smaller image, and it had submitted 5 times before
i realized somethint was going wrong.
(Assignee)

Comment 4

16 years ago
maybe i'll create a test server that uses raw sockets, to test that. is odd that
a server is that busy so that it does not handle the TCP/IP duties first. well,
if i get some time this week i will test to see. i'm interrested too in this thing.
(Reporter)

Comment 5

16 years ago
Additional information: I believe this to happen on multiple builds, but the 
specific LiveJournal user who submitted the support request prompting me to 
post this wrote thus:

"I'm running Mozilla 1.0.1, on two different machines, one running Windows 98, 
the other Windows NT."

Again, I think the problem is broader than that, but if you are having 
difficulty reproducing the bug, you may wish to focus on that browser version 
on those two platforms.

Thank you very much for your help.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Please reopen if you can reproduce this with a recent build
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.