java applets steal focus from page

RESOLVED INVALID

Status

()

Core
Event Handling
--
major
RESOLVED INVALID
15 years ago
3 months ago

People

(Reporter: Mark Williamson, Unassigned)

Tracking

({access, sec508})

Trunk
mozilla1.9alpha8
x86
Windows XP
access, sec508
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ Too difficult to change for Mozilla1.8 ])

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126

Upon loading http://news.bbc.co.uk, page up/down and cursor movements do not
work until somewhere on the page has been clicked. It appears that initially the
page is in focus, but as soon as the java news ticker (at the top) initialises,
the page loses focus. This is very annoying :(

I'm using Java Plug-in 1.4.1.



Reproducible: Always

Steps to Reproduce:
1.Go to http://news.bbc.co.uk
2.Wait for page to load
3.

Actual Results:  
Page up/down etc do not function; the page is unfocused

Expected Results:  
Page up/down etc should function; the page should be in focus

http://news.bbc.co.uk is the only site that I have found so far that does
this... hence I'm assuming the problem is linked with the java news ticker

Comment 1

15 years ago
I also noticed this at http://news.bbc.co.uk/.  Initially, I can't scroll the
page or use shortcuts like Ctrl+U, but I can tab out in order to use other
keyboard commands.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Page loses focus after loading java news ticker → java applets steal focus from page

Comment 2

15 years ago
*** Bug 186499 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
See also bug 160192, loading a Java applet steals focus from other Mozilla windows.

Comment 4

15 years ago
It should be noticed, that this bug does not only affect the applet tag. There
the tabindex parameter and the focusing behavior is not defined. So this could
be considered "by design".

The bug affects also the object tag (see Bug 186499), where tabindex IS defined
and this behavior is clearly a bug.

Comment 5

15 years ago
*** Bug 126512 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
*** Bug 181203 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
Can the Sun team look into this?
Severity: normal → major
Keywords: access, sec508

Comment 8

14 years ago
the BBC news page now uses javascript rather than an applet (actually I think
they may be doing browser detection and serving the applet to unrecognised
browsers - Mozilla and Firefox get the script version)

Updated

12 years ago
Target Milestone: --- → mozilla1.9beta

Updated

12 years ago
Whiteboard: [ Too difficult to change for Mozilla1.8 ]

Comment 9

12 years ago
We need a new test case.

Updated

12 years ago
Assignee: saari → mats.palmgren

Comment 10

9 years ago
sun bug it cited in Bug 160192 (which I just closed) is duped to bug that sun has closed http://bugs.sun.com/bugdatabase/view_bug.do;jsessionid=fac0e38114d6683fd66ba3735c8e4?bug_id=4984794

close incomplete?
I'ld tend so, yes. What do others think?
Assignee: mats.palmgren → nobody
QA Contact: rakeshmishra → events

Comment 12

7 years ago
Testcases are included in the Java JDK. No need to write anything. Any applet, havubg GUI controls or not, even a simple clock will do it, with the latest JDK will do it:

java version "1.6.0_21"
Java(TM) SE Runtime Environment (build 1.6.0_21-b07)
Java HotSpot(TM) Client VM (build 17.0-b17, mixed mode, sharing)

Sun/Oracle have an open bug for this:

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6921946

With this kind of problem, any web master should remove all applets from the site, because any keyboard commands like bookmark page or even cut and paste will not work. So Oracle is wasting all their money pushing JavaFX because it does not work when deployed on web pages.
The HTML <applet> element and related java functionality was removed from Gecko in Bug 1279218. Marking related bugs as invalid.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.