Junk Status not appearing as criteria choice in all accounts...

RESOLVED DUPLICATE of bug 185937

Status

MailNews Core
Filters
RESOLVED DUPLICATE of bug 185937
16 years ago
10 years ago

People

(Reporter: laurel, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Using dec02 commercial trunk

The Filters UI currently shows Junk Status as a filter criteria choice on POP
accounts, but not under IMAP.

Junk Status eventually should be available for all accounts (online and
offline), particularly for use in using manual filtering (Run Filters Now/On
Selected Folder).

Comment 1

16 years ago
I thought I was going insane with this one. at least a relnote would be helpful. 

Comment 2

16 years ago
until the search backend is smart enough to know how to mix server and
client-side search terms, we can't fix this.
Assignee: naving → sspitzer
I fixed this recently.

here's what we decided:

yes, "has attachment" and "junk status" can work for local mail filters, after
the fact, they don't work for incoming mail.

we don't know those things until after we've either read, or analyzed the
message for junk.

so allowing them the user to make filters for these is problematic, since the
filters won't work.

we do allow the user to make views for junk status and has attachment, so that,
plus "select all, move" is as close as you'll get to having an after the fact
filter.



*** This bug has been marked as a duplicate of 185937 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
QA Contact: laurel → nbaca
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.