Closed Bug 183269 Opened 17 years ago Closed 15 years ago

DHTML prob, first appearing in Mozilla 1.2 NOT resolved in 1.2.1

Categories

(Core :: DOM: Core & HTML, defect, major)

x86
Windows 98
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: Telstar-Mail, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130

JavaScript Code for an absolute positioned <div> - properly running under
Navigator 4 (with layers), under MSIE 4.01 and up, and under Mozilla 0.99 and up
- but NOT under Mozilla 1.2 - does also NOT result in proper DHTML-display, in
spite of the "resolved" bug #182500...

PLZ see also my comments and attachments under #182500 !


Reproducible: Always

Steps to Reproduce:
1. Go to www.telstar.int.tf
2. click on one of the server links
3. Voila - see the flickering DHTML-display - and compare with 1.0.1

Actual Results:  
I'm going to step back to v1.0.1 ... 8-(

Expected Results:  
Same results as all other mentioned browsers -- a stable, smooth display !

My JavaScript was already subject to another bug, 'cause I earlier used the
element-method "offsetWidth", which have never functioned properly in Mozilla/5
and have always postponed to the "next" release...

I think this way of working is typical for the complete team. Don't you think,
it would be better to resolve ALL known bugs, before going to new features?
Of course this new code will likely cause new bugs!

Anyway in its current state the Mozilla 1.2 branch is a bogus flop ...
OK.  So I load http://80.150.6.141/home/320038579142/ and I see some
bright-colored text come zooming out at me (Linux trunk build 2002-12-02-21).
This is the same behavior I see in 1.0.1.

Could you please _clearly_ describe what the problem is?
Well - if you see that Arial text "Telstar's Orbit also brings you: The New
Disc Times" splitted in single words in three colours, then it seems OK in
Linux...

Maybe the Linux and Win32 builds are different in this case.
I use Win 98 as you see from the User Agent and here that text is flickering,
tremendously!
Keywords: regression
WFM: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Athlon 1GHz CPU / 256 MB Ram
wfm 2002120208/win98
Could this be graphic cards related?
We have some problems in scaling (actually just images so far).
@reporter: please exactly specify your system settings.
Also see Bug 170702, an unconfirmed bug about flickering regression under
Windows 98.
Well - Markus,
don't know, what you exactly mean here with "system settings" ?! I've got an
Intel BX440 board with a 350MHz PII and an onboard nVidia RIVA 128ZX
AGP-chipset. The settings for the 'Graphics' were 'standard' hitherto (max.
hardware-acceleration).  Commonly I use a 16bit color-depth . Due to the
mentioned bug by Jose, I also tried to pull out any acceleration, but this
doesn't help...

And indeed Jose,
your mentioned bug #170702 is also visible to me in a similar way as you see the
INTRO on my site.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130


Works.
I'd like to mention, this bug continues to appear in mozilla-win32-1.4b, too...
PLZ check the initially given link to confirm!
PLZ use your browser (mozilla all versions above 1.1) and view this to
demonstrate the flickering prob under WINDOWS.

Mozilla 1.0.2 / Netscape 7.0.2
and Netscape 4.08, MSIE, and Opera7.1 work fine....
PLZ use your browser (mozilla all versions above 1.1) and view this to
demonstrate the flickering prob under WINDOWS.

Mozilla 1.0.2 / Netscape 7.0.2
and Netscape 4.08, MSIE, and Opera7.1 work fine....
Confirmed on W2k, various machines with various video cards. (SIS, ATI). At one
point it DID display smoothly, so I can see what it is supposed to do.

Mozilla/5.0 (Windows; U; Windows NT 5.0; es-ES; rv:1.5) Gecko/20030916

However, I don't know enough javascript to tell if the test page is correctly
coded to standard or if it depends on propietory elements?

Well - in the meantime for me it's not that interesting any more what bug is a
dupe of which other one! The only INTERESTING thing is:

When will this issue be resolved, finally!

As you may easily see from the source-code of my example, there's nothing
special, which is blocking a bug-resolution. The bug is only existing since
version 1.1 and wasn't there in versions 1.0.x

Now we are after v1.5 and no chance to fix this???
A shame I think...
->DOM HTML
Assignee: asa → dom_bugs
Component: Browser-General → DOM HTML
QA Contact: asa → ian
I have simplified the testcase by removing the surrounding HTML.  Reporter, do
you see the same problem in this testcase?

Also, both testcases WFM on Win XP Home SP2 with Firefox Nightly.
Yes, fixed now in current trunk build, I can see the bug still in Mozilla1.7.
Probably fixed by bug 244366.
Status: NEW → RESOLVED
Closed: 15 years ago
Depends on: 244366
Resolution: --- → WORKSFORME
Component: DOM: HTML → DOM: Core & HTML
QA Contact: ian → general
You need to log in before you can comment on or make changes to this bug.