Closed Bug 1833071 Opened 1 year ago Closed 1 year ago

Unread folders in folder pane missing some folders with unread messages

Categories

(Thunderbird :: Folder and Message Lists, defect, P2)

Thunderbird 113

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: tawn, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: regression, Whiteboard: [closeme 2023-07-15][Supernova3p])

Steps to reproduce:

Enable "Unread" folders in the folder pane with unread messages in sub-folders of "Local Folders"

Actual results:

When opening Thunderbird some sub-folders of Local Folders do not show under the list of Unread Folders despite having unread messages.

This affects different folders at different times (frequently some show while others do not). Opening the folder and then reading a message in that folder tends to make Thunderbird recognize that the folder truly does have unread messages, and then it appears under Unread Folders at least until Thunderbird is closed. Other times Thunderbird eventually shows them without this interaction.

Expected results:

All folders with unread messages should appear consistently without requiring excessive waiting or further user interaction.

Whiteboard: Supernova

Same problem in 114.0b1 ?

Flags: needinfo?(stayopenmenu)
Keywords: regression
Whiteboard: Supernova → [Supernova3p]

(In reply to Wayne Mery (:wsmwk) from comment #1)

Same problem in 114.0b1 ?

Yes. It's intermittent; sometimes it shows all the folders with unread, sometimes none, more frequently some. Folders with unread that haven't been opened/read in a long while seem most prone to not show up. Unlike the other poster in the linked topicbox thread, I don't tend to keep Thunderbird open for long periods of time on the computer using the beta version, so I'm less likely to see if they eventually show up.

Have only been on 114.0b1 for short time; if I can discern any further details over time, will post them.

Flags: needinfo?(stayopenmenu)

Toggling 'Unread Folders' off & back on thru either folder pane options or via the menubar will make all of those unread folders become visible (until restarting Tbird).

Workaround: Found that if I keep 'Folder Modes' > All Folders toggled on, the issue does not seem to occur.

With (in folder pane) :
Unified Folders
Unread Folders
All Folders (all '>' subitems can be left in collapsed state)
--working properly

With just:
Unified Folders
Unread Folders
--issue still occurs in v114.0b5

Severity: -- → S3
Priority: -- → P2

Reporter, do you still see this when using the latest beta?

Flags: needinfo?(stayopenmenu)

Since Local Folders started appearing in Unified Folders, I haven't been displaying Unread Folders. I turned it back on for testing today; so far not seeing issue (so likely fixed, but it was intermittent). Will leave it on and report back if it recurs.

Flags: needinfo?(stayopenmenu)

Thanks. Will leave this open for another week.

Whiteboard: [Supernova3p] → [closeme 2023-07-15][Supernova3p]

Closing as WORKSFORME . Despite actively attempting to trigger the bug, I can no longer reproduce.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.