Closed Bug 183389 Opened 22 years ago Closed 20 years ago

[gtk2] porting xpinstall to gtk2

Categories

(SeaMonkey :: Installer, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: iamawalrus, Assigned: ajschult784)

References

Details

Attachments

(2 files, 1 obsolete file)

xpinstall need port to gtk2
Attached patch patch (obsolete) — Splinter Review
Attachment #108147 - Flags: superreview?(blizzard)
Attachment #108147 - Flags: review?(sgehani)
*** Bug 191828 has been marked as a duplicate of this bug. ***
Comment on attachment 108147 [details] [diff] [review]
patch

Could you explain why you have forked the code when so much of it looks the
same?  Also could you please attach diffs between the *GTK2.{h,cpp} classes and
the original classes.  

What is the plan to move to GTK2?  Are we going to tranistion mozilla to switch
over entirely any time soon?  If so, maybe just using macros (if only needed in
few places) would be sufficient for now and we could remove them and supprt for
GTK 1.2 once we make the transition.

As it stands it is hard to recognize what this patch has changed.
Attachment #108147 - Flags: review?(sgehani) → review-
I did so just because if some day we want to totally seperate the two install
wizards, it might be easier. It's just my concern. If you think it's better to
use macro to seperate them, I can provide a new patch. 

I do not know mozilla.org's plan for GTK2. I guess it might not be a complete
switch and mozilla for gtk1.2 and gtk2.0 would coexist for a while. However,
there are a lot of people interested in moz+gtk2 and want it could be released soon.
Attachment #108147 - Flags: superreview?(blizzard)
Attached patch patchSplinter Review
This patch ueses macro instead of create new files.
Attachment #108147 - Attachment is obsolete: true
Attachment #114394 - Flags: review?(sgehani)
Robin: I think Samir (sgehani) is very gone.

==> Installer
Component: XP Toolkit/Widgets → Installer
QA Contact: jrgmorrison → nobody
Robin: Does the patch work with the existing trunk? (I ask, cause the patch is
very old :-))
Attachment #114394 - Flags: review?(sgehani)
I think the patch mostly works for the trunk since there's not many changes in
this part of code. I will update the patch if needed.
Comment on attachment 114394 [details] [diff] [review]
patch

Robin: I broke this patch in a few places with "silent" mode and removal of the
completion dialog.  I'm trying out the patch now.

So far, I've noticed the gtk2 installer complaining:
(mozilla-installer-bin:16149): Gtk-WARNING **: gtkwidget.c:3697: widget not
within a GtkWindow

from
http://lxr.mozilla.org/seamonkey/source/xpinstall/wizard/unix/src2/nsXInstaller
.cpp#315

    GTK_WIDGET_SET_FLAGS(gCtx->next, GTK_CAN_DEFAULT);
    gtk_widget_grab_default(gCtx->next);

the code should go farther down (after gCtx->next has been attached).  I put it
right above the gtk_widget_show calls, and it works fine (gtk1 and gtk2).

Also, the text area for the README and License looks different in the gtk2
version.  The gtk1 version has a border and the gtk2 does not.	Is there any
way to add that back in for the gtk2 version?

If you attach a new patch, remember to not add any new tabs (the files already
have some tabs randomly dispersed).
I forgot to mention, there's also 'error: invalid conversion from `const gchar*'
to `char*' here:
http://lxr.mozilla.org/mozilla/source/xpinstall/wizard/unix/src2/nsSetupTypeDlg.cpp#662

   char *selDir = gtk_file_selection_get_filename(
                     GTK_FILE_SELECTION(aFileSel));
> the code should go farther down (after gCtx->next has been attached).  I put it
> right above the gtk_widget_show calls, and it works fine (gtk1 and gtk2).
I did the same thing as you in my working patch


> I forgot to mention, there's also 'error: invalid conversion from `const gchar*'
> to `char*' here:
I have changed the "char*" to "const char*"
Depends on: 130121
bryner just checked in a gtk2 installer for firefox/thunderbird...
it's in mozilla/toolkit/mozapps/unix/wizard
How to get this for Mozilla Seamonkey?
I still use the GTK1 mozilla-installer-bin from the official release and put it
in /xpinstall/wizard/unix/src2/ before using "perl deliver.pl" in
/xpinstall/packager/unix/. But this is not very smart!
Attached patch updated patchSplinter Review
this is Robin's patch, merged to trunk and just removing the use of packer
instead of #ifdef'ing it out.
Attachment #160207 - Flags: review?(dveditz)
Comment on attachment 160207 [details] [diff] [review]
updated patch

r=dveditz
Attachment #160207 - Flags: review?(dveditz) → review+
Attachment #160207 - Flags: superreview?(bryner)
me
Assignee: robin.lu → ajschult
Product: Browser → Seamonkey
Attachment #160207 - Flags: superreview?(bryner) → superreview+
Flags: blocking1.8b2?
fixed
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: