Closed Bug 1834510 Opened 1 year ago Closed 1 month ago

Show folder size on main collapsed folder in folder pane

Categories

(Thunderbird :: Folder and Message Lists, task, P3)

Tracking

(thunderbird_esr102 unaffected, thunderbird_esr115 wontfix)

RESOLVED DUPLICATE of bug 1870641
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird_esr115 --- wontfix

People

(Reporter: elijmitchell, Assigned: vineet)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Supernova3p])

Attachments

(1 file, 1 obsolete file)

When the folder size option is enabled, if an email account folder is collapsed, the folder size should be displayed on the folder for the email account.

Assignee: nobody → elizabeth
Status: NEW → ASSIGNED
Priority: -- → P2
Whiteboard: [Supernova3p]
Blocks: sn-folderpane
No longer blocks: sn-fp-options
Assignee: elizabeth → vineet

I have the same problem. Will this be fixed soon?

Seems like the sizeOnDisk parameter is returning 0 for the rootFolder for the server. Could use a little more info on this.

Flags: needinfo?(brendan)

For clarity of my comment..
The previous version of Thunderbird before Nova showed me the accumalated size totals of folders/subfolders for each email account I have.
Now it only shows the size of each seperate folders, it does not include the sub folders.

See Also: → 1870641
Depends on: 1873684

Seems like the sizeOnDisk parameter is returning 0 for the rootFolder for the server. Could use a little more info on this.

I've had a look at the backend side of this and opened bug 1873684 - where I've also written down my conclusions - to track and solve this. I think it's better to tackle that part in a separate bug since I think there will still be work left on the frontend to access the correct data.

Flags: needinfo?(brendan)

Bug 1873684 is now resolved. nsIMsgFolder objects now have a sizeOnDiskWithSubFolders read-only attribute, which when queried retrieves the size of all sub-folders to add it to the current one. Note that this means this operation can potentially become a bit expensive if a folder has e.g. several hundreds sub-folders.

Depends on: 1883602
Duplicate of this bug: 1883602
Severity: -- → N/A
Priority: P2 → P3
Attachment #9388867 - Attachment is obsolete: true

It seems to me that this bug is fixed in TB 128.0a1 (or I misunderstood something)

(In reply to Nicolas Mandil (:NicolasWeb) from comment #8)

Created attachment 9402557 [details]
Tb 128.0a1 - Account folder disk size.jpg

It seems to me that this bug is fixed in TB 128.0a1 (or I misunderstood something)

Flags: needinfo?(vineet)

Yes, we have a current solution that works as intended. Will mark this resolved as a duplicate.

Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Duplicate of bug: 1870641
Flags: needinfo?(vineet)
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: