Closed Bug 18347 Opened 20 years ago Closed 20 years ago

HTML button name attribute does not work

Categories

(Core :: Layout, defect, P3)

All
Windows NT
defect

Tracking

()

VERIFIED INVALID

People

(Reporter: teruko, Assigned: rods)

References

()

Details

HTML button name attribute does not work.

Steps of reproduce
1. Go to above URL
2. Click on "this is button1"

Expected result
   two buttons depress, "this is button1" and "this is button2"
   since these two buttons have same button name

Actual result
   Only first "this is button1" button is depressed.

Tested 110809 Win32, Mac, and Linux build.
Assignee: rickg → rods
Rod -- is this a legit bug? Should both button depress?
Assignee: rods → evaughan
reassigning to evaughan
Whiteboard: needs evaughan triage
Status: NEW → ASSIGNED
Summary: HTML buttun name attribute does not work → HTML button name attribute does not work
Whiteboard: needs evaughan triage
Target Milestone: M14
Target Milestone: M14 → M15
Rod,

I'm handing html4 buttons back to you. I have way to much to do with all the xul  
layout stuff I'm already doing. Let me know if thats ok.
Assignee: evaughan → rods
Status: ASSIGNED → NEW
According to the DTD, the name attribute assigns a control name only. The value 
assigned to name attribute can be shared among other buttons so that they may be 
grouped in a category inside a form. I think this test case is bogus since it's 
not suppose to apply focus on any buttons that happen to share the same name 
value.
Marking as invalid
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
Marking as verified invalid
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.