Closed Bug 1836507 Opened 1 year ago Closed 1 year ago

Tab history from one SERP to another can be recorded as a non-ad click

Categories

(Firefox :: Search, defect, P2)

defect

Tracking

()

RESOLVED FIXED
116 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox-esr115 --- fixed
firefox114 --- unaffected
firefox115 --- fixed
firefox116 --- fixed

People

(Reporter: jteow, Assigned: jteow)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [snt-scrubbed])

Attachments

(1 file)

As mentioned in Bug 1835267, the tab history can trigger a "click" event due to the fact that the URL matches a SERP, as we've made the allowable non ad links more permissive.

Could be the same with bookmarks or manually entering a URL that's a SERP? It might a timing issue.

Digging deeper into this, the reason why we don't hit this issue with launching requests of SERP urls from the Urlbar or loading bookmarks of SERPs is because the originURL will be null, thus we won't find an item and we'll early return.

Using Back/Forward is slightly different. Because we're now subscribing to cache events (so that we record clicks on non ad links that could be cached), SERPs can be accessed via a cached event.

Whiteboard: [snt-scrubbed]
Summary: Tab history from one SERP to another be recorded as a non-ad click → Tab history from one SERP to another can be recorded as a non-ad click
Attachment #9337479 - Attachment description: Bug 1836507 - Prevent some tab-history events from triggering a click event - r?standard8,scunnane → Bug 1836507 - Prevent tab-history events from triggering a click event - r?standard8,scunnane
Pushed by jteow@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/66459654cc98
Prevent tab-history events from triggering a click event - r=Standard8
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 116 Branch

The patch landed in nightly and beta is affected.
:jteow, is this bug important enough to require an uplift?

  • If yes, please nominate the patch for beta approval.
  • If no, please set status-firefox115 to wontfix.

For more information, please visit BugBot documentation.

Flags: needinfo?(jteow)
Blocks: 1835267
Duplicate of this bug: 1835267

Opting for wontfix in 115 because we haven't validated the data for current users in Nightly yet, so there's a strong chance the full experiment won't be run on release till post-115.

Flags: needinfo?(jteow)

(In reply to James Teow [:jteow] from comment #7)

Opting for wontfix in 115 because we haven't validated the data for current users in Nightly yet, so there's a strong chance the full experiment won't be run on release till post-115.

We have decided to uplift the fix to 115 dot release to run the experiment earlier.

Comment on attachment 9337479 [details]
Bug 1836507 - Prevent tab-history events from triggering a click event - r?standard8,scunnane

Beta/Release Uplift Approval Request

  • User impact if declined: Improvement to new Search SERP Ad telemetry that we would like to turn on a bit earlier. Improves handling of reporting when using tab history.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small change to telemetry-only analysis code in a well-tested area.
  • String changes made/needed: None
  • Is Android affected?: No
Attachment #9337479 - Flags: approval-mozilla-release?

Comment on attachment 9337479 [details]
Bug 1836507 - Prevent tab-history events from triggering a click event - r?standard8,scunnane

Approved for 115.0.2
Approved for 115.0.2esr

Attachment #9337479 - Flags: approval-mozilla-release? → approval-mozilla-release+
Attachment #9337479 - Flags: approval-mozilla-esr115+

Tagging as a qe- for this issue. We have tcs coverage and verification has been done for bug 1835267 which is a particular case while this is the general one.

Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: