Closed Bug 1836515 Opened 1 year ago Closed 10 months ago

Firefox freezes complete Ubuntu 20.04.1 LTS system: nsUserIdleServiceGTK::PollIdleTime repeatedly calls GDK_DISPLAY_XDISPLAY,libXss,libX11,libxcb.

Categories

(Core :: Graphics: WebRender, defect, P2)

Firefox 113
Desktop
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1847699

People

(Reporter: mindboosternoori, Unassigned)

References

()

Details

(Keywords: hang)

Crash Data

+++ This bug was initially created as a clone of Bug #1664798 +++

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:80.0) Gecko/20100101 Firefox/80.0

Steps to reproduce:

Recently updated from Ubuntu 18.04 to Ubuntu 20.04.1 LTS after that when ever i open firefox after visit any website.

Actual results:

After doing some surfing entire system freeze's noting happens only option left is to restart the system

Expected results:

It does not happen using any other application only it happens in fire fox

+++ Reason for cloning Bug #1664798 +++
While this issue was marked as closed (with a 'worksforme') the freezes still happen at least to some of us. I'm not sure if the issue is the same, or only the symptoms are.

Here are two crash reports of it:
https://crash-stats.mozilla.org/report/index/5b18b969-5325-48b2-a408-e4fe90230529
https://crash-stats.mozilla.org/report/index/3f997b6c-01f7-445f-bc03-5b6130230602

Changed the "version" field to "Firefox 113" as that's where I still see the issue happening, but I've been suffering this behavior for years now, so the issue isn't new.

See Also: → 1664798
Crash Signature: [@ libxcb.so.1@0xbc19 ]
Keywords: hang
See Also: → 1814586, 1743551
Summary: [WebRender/EGL] Firefox freezes complete Ubuntu 20.04.1 LTS system → Firefox freezes complete Ubuntu 20.04.1 LTS system: nsUserIdleServiceGTK::PollIdleTime repeatedly calls GDK_DISPLAY_XDISPLAY,libXss,libX11,libxcb.

Martin, is there anything we could do to reduce the number of calls into _XSSQueryInfo there so that we reduce our exposure to this race condition in libxcb/libX11?

Flags: needinfo?(stransky)
See Also: → 1836668

The bug has a crash signature, thus the bug will be considered confirmed.

Status: UNCONFIRMED → NEW
Ever confirmed: true

Uselessly chiming in: I've been using Ubuntu 20.04.1 LTS pretty frequently over the past week (using the default GNOME desktop), and I have not experienced this myself using Fx113.0.2. I did not upgrade from 18, however. Mine is a fresh install.

Severity: -- → S3
Priority: -- → P2

Also KDE provides its own idle monitor used by KDE/Sway.

I just had a "similar" hang that produced a different crash report, so I'm adding that info here in case it is useful:
https://crash-stats.mozilla.org/report/index/c7d86040-f773-4b9c-ba27-9cc690230705

From an user perspective they both seem to be the same issue (at least the machine had the same behavior in both), but I'm not sure they both point to the same root cause.

Crash Signature: [@ libxcb.so.1@0xbc19 ] → [@ libxcb.so.1@0xbc19 ] [@ mozilla::glean::GetLabeledMirrorLock ] [@ nsWindow::OnExposeEvent ]

I did not generate a crash report :-( but this is still happening on 116.0.2.

Should be solved by Bug 1847699 now.

Flags: needinfo?(stransky)
Status: NEW → RESOLVED
Closed: 10 months ago
Duplicate of bug: 1847699
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.