Help page for bug flags doesn't discuss bug flags

RESOLVED WONTFIX

Status

()

bugzilla.mozilla.org
General
P3
normal
RESOLVED WONTFIX
15 years ago
7 years ago

People

(Reporter: Mark Bickford, Assigned: justdave)

Tracking

Details

(URL)

Attachments

(4 attachments, 4 obsolete attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

The Help! page for Bug Flags, http://bugzilla.mozilla.org/flag-help.html, only
discusses Attachment Flags, and is in fact entitled "How the New Attachment
Statuses Work".  While the actual meanings of the SELECT options (+ / - / ?) is
the same for both flag types, the help page should also discuss what the Bug
Flags themselves are for.  I'm guessing that they are equivalent to keyword
targeting (e.g., nsbeta+), but the reason for help pages is that so users don't
have to guess at functionality.

Reproducible: Always

Steps to Reproduce:
1. Open any Mozilla bug
2. Click on the "Help!" link next to the Flags caption at right


Actual Results:  
I was taken to an explanation of Attachment Flags

Expected Results:  
I should have been taken to a page that explained what Bug Flags are for.  This
information could be included in the Attachment Flags page to avoid duplicating
the explanation of what the SELECT options mean, but it should be available.
flag help page is bmo specific

Theres also anoterh bug about allowing people to see the descriptions for the flags.
Assignee: matthew → endico
Status: UNCONFIRMED → NEW
Component: Documentation → Bugzilla: Other moz.org Issues
Ever confirmed: true
Product: Bugzilla → mozilla.org
QA Contact: matty → myk
Version: unspecified → other

Comment 2

14 years ago
Somebody PLEASE fix this. It's been two years since it was reported and it makes
it hard for the general public to understand the status of bugs.
The page in question discusses attachment flags as "here's how they're different
from what we used to have" perspective.

Bug flags were a completely new thing.

This is also a local hack, and it's been plenty long enough for people to have
completely forgotten all about the old attachment statuses.

In my opinion we need to remove this page outright from b.m.o (it's a local
hack) and get the help for it and/or visible descriptions dealt with upstream in
Bugzilla itself.
Assignee: endico → justdave
Blocks: 280371
Priority: -- → P3

Comment 4

13 years ago
Created attachment 182977 [details]
Explanation of the flags

Very basic like the old page...for temp use until a permanent page can be
created. Updated pic in next attacment

Comment 5

13 years ago
Created attachment 182978 [details]
replacement picture

Updated

13 years ago
Attachment #182977 - Attachment is obsolete: true

Comment 6

13 years ago
Created attachment 182979 [details]
left aligned picture

aligned the picture on the left, looked weird in center

Updated

13 years ago
Attachment #182979 - Attachment mime type: image/png → text/html

Updated

13 years ago
Attachment #182979 - Attachment is obsolete: true

Comment 7

13 years ago
Created attachment 182983 [details]
looks like bugzilla.org support pages now

no more plain html, looks like the support pages now. only thing someone will
have to edit is the bottom part where it says " Document History  Edit this
Page " I donno how exactly that works, so i'll let you guys figure that out.

Updated

13 years ago
Attachment #182978 - Attachment filename: flags.PNG → flags.png

Updated

13 years ago
Attachment #182983 - Attachment is obsolete: true

Comment 8

13 years ago
Created attachment 182986 [details]
last time

sorry last version was done expect for the links somehow got converted to local
file system. links updated to correct locations expect for one that you guys
will have to change for wherever the first attachment will be located. change
the address of this line

<img src="https://bugzilla.mozilla.org/attachment.cgi?id=182978">

sorry about all the attachments and obsoletes. and just seen that I could
'Check each existing attachment made obsolete by your new attachment.'

Comment 9

13 years ago
Comment on attachment 182986 [details]
last time

also marking this obsolete based on gavins comment on irc to make it more
generic, with examples for the common flags.

will do that in coming days since I have to exams to studyfor/take
Attachment #182986 - Attachment is obsolete: true

Comment 10

13 years ago
Created attachment 183031 [details]
review-flags picture

Comment 11

13 years ago
Created attachment 183032 [details]
another attempt

only thing that will need to be changed is the link to the two pictures and the
links at the bottom to edit the page via the cvs

Comment 12

13 years ago
Created attachment 183037 [details]
previous attachment tweaked a little

An HTML definition list makes more sense semantically. Tweaked the text a
little too.

Comment 13

13 years ago
Is there a page anywhere on the site that explains what the codenames such as
'aviary' mean? A link to that from the flags page would be useful.

I also wonder whether there should be two definition lists, one for bug flags
and one for patch flags, since they are unrelated.
Surely this general information needs to go in the Bugzilla Guide?

Flags should probably have descriptions, viewable by tooltips when mousing over
them. That would make it easier for people to understand what they are for.

Gerv
This page will be gone with tonight's upgprade.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.