Closed Bug 1837602 Opened 1 year ago Closed 1 year ago

Disable Spectre JIT mitigations in Fission content processes

Categories

(Core :: JavaScript Engine, task, P1)

task

Tracking

()

RESOLVED FIXED
116 Branch
Tracking Status
firefox116 --- fixed

People

(Reporter: jandem, Assigned: jandem)

References

(Blocks 1 open bug)

Details

(Keywords: perf-alert)

Attachments

(1 file)

Filing this bug to track flipping the javascript.options.spectre.disable_for_isolated_content pref when we're ready.

Summary: Disable Spectre mitigations in Fission content processes → Disable Spectre JIT mitigations in Fission content processes

I think we should start first Nightly only, that is where ORB has been enabled for some time now.

(In reply to Olli Pettay [:smaug][bugs@pettay.fi] from comment #1)

I think we should start first Nightly only, that is where ORB has been enabled for some time now.

Agreed. Enabling it Nightly-only soon is what we were thinking and then later we can let it ride the trains.

Severity: -- → S3
Priority: -- → P1
Assignee: nobody → jdemooij
Status: NEW → ASSIGNED
Duplicate of this bug: 1815170
Pushed by jdemooij@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/47d6f0032249
Disable JS Spectre mitigations for Fission content processes in Nightly. r=iain
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 116 Branch

I seem Fission have not enabled for Android yet (Bug 1610822?)
https://searchfox.org/mozilla-central/rev/6755226f52a02eac8b18f25a6f522e9c0814b628/modules/libpref/init/StaticPrefList.yaml#5142

We need still enable this mitigation for Android even if Nightly build?

(In reply to Tetsuharu OHZEKI [:tetsuharu] (UTC+9) from comment #7)

We need still enable this mitigation for Android even if Nightly build?

Mitigations are still enabled on Android because we only disable them for Fission isolated processes. See here.

(In reply to Jan de Mooij [:jandem] from comment #8)

(In reply to Tetsuharu OHZEKI [:tetsuharu] (UTC+9) from comment #7)

We need still enable this mitigation for Android even if Nightly build?

Mitigations are still enabled on Android because we only disable them for Fission isolated processes. See here.

Thank you!

== Change summary for alert #38896 (as of Tue, 27 Jun 2023 23:24:04 GMT) ==

Improvements:

Ratio Test Platform Options Absolute values (old vs new)
37% perf_reftest_singletons getElementById-1.html windows10-64-shippable-qr e10s fission stylo webrender 47.42 -> 29.79
11% kraken linux1804-64-shippable-qr e10s fission stylo webrender 1,370.08 -> 1,218.18
9% kraken windows10-64-shippable-qr e10s fission stylo webrender 1,140.08 -> 1,040.41
8% dromaeo_css windows10-64-shippable-qr e10s fission stylo webrender 19,346.58 -> 20,888.91
3% pdfpaint linux1804-64-shippable-qr e10s fission stylo webrender-sw 753.63 -> 730.87

For up to date results, see: https://treeherder.mozilla.org/perfherder/alerts?id=38896(In reply to Pulsebot from comment #5)

Pushed by jdemooij@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/47d6f0032249
Disable JS Spectre mitigations for Fission content processes in Nightly.
r=iain

Keywords: perf-alert
Regressions: 1841234
Blocks: 1851162
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: