Closed Bug 1839005 Opened 1 year ago Closed 3 months ago

"Find in this message" no longer works for neither the multi-message view nor viewing a web page in the 3-pane view

Categories

(Thunderbird :: Mail Window Front End, defect, P2)

Thunderbird 115

Tracking

(thunderbird_esr102 unaffected, thunderbird_esr115?)

RESOLVED FIXED
126 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird_esr115 ? ---

People

(Reporter: standard8, Assigned: vineet)

References

Details

(Keywords: regression)

Attachments

(1 file)

In the latest Thunderbird nightly, it is not possible to do the equivalent of "Find in this message" in neither the multi-message views nor the web page (e.g. start page) view in the 3-pane view.

I have previously fixed the multi-message views in bug 1719100. The web browser view seems to be a new issue, but probably related.

This also breaks find for the Conversations add-on which was a previously requested feature.

The 2023-06-17 daily was kind of a bust (if that's the one you're referring to). Is 115 affected?

(In reply to Magnus Melin [:mkmelin] from comment #1)

The 2023-06-17 daily was kind of a bust (if that's the one you're referring to). Is 115 affected?

Sorry, I forgot to mention beta is also broken.

Severity: -- → S3
Priority: -- → P2
Version: unspecified → Thunderbird 115
Assignee: nobody → brendan
Status: NEW → ASSIGNED

I've (finally) had a look at this. It looks like the multiMessageBrowser and the webBrowser in about3Pane.xhtml are both missing a findbar element (ref). This isn't an issue with the messageBrowser as about:message already includes one: https://searchfox.org/comm-central/rev/2b0981c16947355d133f494a88c3a6853596fc22/mail/base/content/aboutMessage.xhtml#153

It's not entirely clear to me where those elements should go (both finbars in about3Pane.xhtml, one in about3Pane.xhtml and one in multimessageview.xhtml, something else?) and it feels to me like there needs to be some layout changes to accommodate for the missing findbars in both impacted browser.

Assignee: brendan → vineet

The findbar needs to be associated with the browser element associate that you want to do the searching within.

Unfortunately due to the new architecture, there's now multiple levels of browser under the messagePane div:

  • webBrowser
    • For web pages, associate with this one.
  • messageBrowser -> (somewhere within this browser) -> messagepane
    • For single messages, associate with this one embedded within the others.
  • multiMessageBrowser
    • For multi-message view, associate with this one.

You can switch the browser that the find bar is associated with - my patch on bug 1719100 did that.

So the findbar probably wants to go at the same level as the <div id="messagePane" ....

Ideally it shouldn't be defined within messageBrowser as well, because then you have two independent find bars in the same space, however, I'm not sure you'd be able to associate it with a browser that's within a browser... though maybe it wouldn't hurt to allow searching the header as well.

In any case, any chance this 8 month old tracking-requested regression could actually be looked at?

Flags: needinfo?(vineet)
Flags: needinfo?(brendan)

(In reply to Mark Banner (:standard8) from comment #4)

The findbar needs to be associated with the browser element associate that you want to do the searching within.

Unfortunately due to the new architecture, there's now multiple levels of browser under the messagePane div:

  • webBrowser
    • For web pages, associate with this one.
  • messageBrowser -> (somewhere within this browser) -> messagepane
    • For single messages, associate with this one embedded within the others.
  • multiMessageBrowser
    • For multi-message view, associate with this one.

You can switch the browser that the find bar is associated with - my patch on bug 1719100 did that.

So the findbar probably wants to go at the same level as the <div id="messagePane" ....

Ideally it shouldn't be defined within messageBrowser as well, because then you have two independent find bars in the same space, however, I'm not sure you'd be able to associate it with a browser that's within a browser... though maybe it wouldn't hurt to allow searching the header as well.

In any case, any chance this 8 month old tracking-requested regression could actually be looked at?

Hi Mark, I'll be taking a look at this over the next couple of days. Thanks for all of the provided info.

Flags: needinfo?(vineet)
Flags: needinfo?(brendan)
Attachment #9388559 - Attachment description: WIP: Bug 1839005 - Add missing findbar in multimessageview and webbrowser in 3pane. → Bug 1839005 - Add missing findbar in multimessageview and webbrowser in 3pane. r=#thunderbird-front-end-reviewers
Target Milestone: --- → 126 Branch

Pushed by micah@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/3ca02632e68d
Add missing findbar in multimessageview and webbrowser in 3pane. r=freaktechnik,aleca

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: