Closed Bug 1839439 Opened 10 months ago Closed 10 months ago

PiP progress bar appears too high for wide videos (21:9) at some window sizes

Categories

(Toolkit :: Picture-in-Picture, defect)

Firefox 116
Desktop
All
defect

Tracking

()

VERIFIED FIXED
116 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox-esr115 --- unaffected
firefox114 --- unaffected
firefox115 --- unaffected
firefox116 --- verified

People

(Reporter: ke5trel, Assigned: niklas, NeedInfo)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

STR:

  1. Visit a youtube video with a wide 21:9 aspect ratio (eg https://youtube.com/watch?v=Ttl8Gg-P-Ao).
  2. Open the video in PiP window.
  3. Resize the PiP window large enough that the volume slider first starts to appear.

Control overlay including progress bar appears too high in frame except for volume slider and timestamp.

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=e0262ee6a9a7a642c11266a1e9cfa4bc3fbd4b3b&tochange=8740be66493fa62886c4df2a8895068ed554ef44

Regressed by Bug 1580095.

:niklas, since you are the author of the regressor, bug 1580095, could you take a look? Also, could you set the severity field?

For more information, please visit BugBot documentation.

Flags: needinfo?(nbaumgardner)
Assignee: nobody → nbaumgardner
Status: NEW → ASSIGNED
Pushed by nbaumgardner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/940739d0aaac
Hide audio scrubber on wide apsect ratio videos. r=pip-reviewers,mhowell
Duplicate of this bug: 1839644
Severity: -- → S3
OS: Unspecified → All
Hardware: Unspecified → Desktop
Pushed by nbaumgardner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3ba9b54b1c29
Hide audio scrubber on wide apsect ratio videos. r=pip-reviewers,mhowell,kpatenio
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 116 Branch

I have verified the fix with multiple videos from HBO Max, PrimeVideo and Youtube using Firefox Nightly 116.0a1 (20230625195949) on Windows 7/10, Ubuntu 20.04 and MacOS 11.6.

Status: RESOLVED → VERIFIED

Set release status flags based on info from the regressing bug 1580095

Regressions: 1841914
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: