Closed Bug 1841097 Opened 1 year ago Closed 11 months ago

Change the ETP Custom Options to include FPP

Categories

(Core :: Privacy: Anti-Tracking, enhancement)

enhancement

Tracking

()

VERIFIED FIXED
118 Branch
Tracking Status
firefox118 --- verified

People

(Reporter: tjr, Assigned: timhuang)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fpp:m5])

Attachments

(3 files)

The ETP Custom Option will have a checkbox added to it to specifically enable/disable FPP.

My suggestion is to change things in the following way:

  • "Choose which trackers and scripts to block" -> "Choose which protections to enable"
  • "Cookies" -> "Block Cookies"
  • "Tracking Content" -> "Block Tracking Content"
  • "Cryptominers" -> "Block Cryptomining Scripts"
  • "Fingerprinters" -> "Block Fingerprinting Scripts"
  • [Add] "Enable Fingerprinting Protections [Learn More]" with a dropdown "Only in Private Windows" and "In all Windows" and where Learn More goes to a new SUMO page about FPP and what is enabled in what version and what you can expect from that.
Whiteboard: [fpp:m?] → [fpp:m7]
Assignee: nobody → tihuang
Status: NEW → ASSIGNED
Attachment #9348583 - Flags: data-review?(chutten)

This patch implements a checkbox in ETP Custom usbpanel. It's for the
configuration of the fingerprinting protection. Similar to the tracking
protection checkbox, it has a dropdown list to select which window to
enable the protection, private windows or all windows.

In addition, we update the existing copy for fingerprinters to reflect
the newly added fingerprinting protectoin checkbox.

This patch adds an event telemetry for fingerprinting protection
checkbox and fingerprinting protection prefs into the telemetry environment prefs.

Depends on D186023

Data Collection Reviews must be made publicly available to the population having their data collected. Will this bug be made public before data collection begins?

Flags: needinfo?(tihuang)

I think we can make this bug public because people will see the UI and know we are developing fingerprinting protection once this bug lands. So, there is no point to hide this bug.

Group: mozilla-employee-confidential
Flags: needinfo?(tihuang)

The Bugbug bot thinks this bug should belong to the 'Core::Privacy: Anti-Tracking' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: General → Privacy: Anti-Tracking
Product: Firefox → Core

Comment on attachment 9348583 [details]
data-request-Bug1841097.md

DATA COLLECTION REVIEW RESPONSE:

Is there or will there be documentation that describes the schema for the ultimate data set available publicly, complete and accurate?

Yes.

Is there a control mechanism that allows the user to turn the data collection on and off?

Yes. This collection can be controlled through Firefox's Preferences.

If the request is for permanent data collection, is there someone who will monitor the data over time?

Yes, Tim Huang is responsible.

Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under?

Category 2, Interaction.

Is the data collection request for default-on or default-off?

Default on for all channels.

Does the instrumentation include the addition of any new identifiers?

No.

Is the data collection covered by the existing Firefox privacy notice?

Yes.

Does the data collection use a third-party collection tool?

No.


Result: datareview+

Attachment #9348583 - Flags: data-review?(chutten) → data-review+
Pushed by tihuang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/24109a1476e6
Implement a checkbox in ETP Custom subpanel for the configuration of the fingerprinting protection. r=anti-tracking-reviewers,fluent-reviewers,flod,bvandersloot,mstriemer
https://hg.mozilla.org/integration/autoland/rev/c850305f1ad8
Add telemetry for the fingerprinting protection checkbox and prefs. r=chutten,anti-tracking-reviewers,settings-reviewers,mstriemer,bvandersloot
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 118 Branch
Regressions: 1849887
Depends on: 1850921
Depends on: 1851474

Verified as fixed on Firefox 118.0b9 and Nightly 119.0a1 - tested on Ubuntu 22.04, macOS 11.7, and Windows 10.

Status: RESOLVED → VERIFIED

Moving this up to FPP M5 milestone

Whiteboard: [fpp:m7] → [fpp:m5]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: