Closed Bug 1842786 Opened 9 months ago Closed 9 months ago

0.26 - 0.25% Base Content JS / Base Content JS (Windows) regression on Fri July 7 2023

Categories

(Core :: JavaScript Engine, defect)

defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr102 --- unaffected
firefox-esr115 --- unaffected
firefox115 --- unaffected
firefox116 --- unaffected
firefox117 --- affected

People

(Reporter: bacasandrei, Unassigned)

References

(Regression)

Details

(Keywords: perf, perf-alert, regression)

Perfherder has detected a awsy performance regression from push 2ef473aa8aa49ccfd1aa15ba9be006a973a238c3. As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

Ratio Test Platform Options Absolute values (old vs new)
0.26% Base Content JS windows11-64-2009-shippable-qr fission 1,584,857.33 -> 1,588,965.33
0.25% Base Content JS windows11-64-2009-shippable-qr fission 1,584,962.67 -> 1,588,953.33

Details of the alert can be found in the alert summary, including links to graphs and comparisons for each of the affected tests. Please follow our guide to handling regression bugs and let us know your plans within 3 business days, or the offending patch(es) may be backed out in accordance with our regression policy.

If you need the profiling jobs you can trigger them yourself from treeherder job view or ask a sheriff to do that for you.

For more information on performance sheriffing please see our FAQ.

Flags: needinfo?(andrebargull)

Set release status flags based on info from the regressing bug 1841113

Bug 1841113 is disabled by default, so any size increase has to be caused by additional static-like data (for example new entries in CommonPropertyNames.h). This isn't something which can be improved, so I guess we just have to accept the size regression.

Status: NEW → RESOLVED
Closed: 9 months ago
Flags: needinfo?(andrebargull)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.