Closed Bug 1842890 Opened 8 months ago Closed 7 months ago

Add splash screen animation

Categories

(Fenix :: Onboarding, enhancement)

All
Android
enhancement

Tracking

(firefox116 verified, firefox117 verified)

VERIFIED FIXED
117 Branch
Tracking Status
firefox116 --- verified
firefox117 --- verified

People

(Reporter: royang, Assigned: royang)

References

Details

(Whiteboard: [fxdroid])

Attachments

(3 files)

Add animated splash screen to first run users.

Assignee: nobody → royang
Whiteboard: [fxdroid]
Status: NEW → RESOLVED
Closed: 7 months ago
Flags: qe-verify+
Resolution: --- → FIXED
Target Milestone: --- → 117 Branch

Authored by https://github.com/rvandermeulen
https://github.com/mozilla-mobile/firefox-android/commit/d9ac231b1804296c61c62788a32e8b87cb14ea94
[main] Revert "Bug 1842890 - Add splash screen animation" for breaking gradle-dependencies jobs.

Backed out for causing Fenix gradle-dependencies job bustage.
https://github.com/mozilla-mobile/firefox-android/commit/d9ac231b1804296c61c62788a32e8b87cb14ea94

Log:
https://firefox-ci-tc.services.mozilla.com/tasks/UpXRtaRYRuaYlMjBg4SLlA/runs/5/logs/public/logs/live.log

org.mozilla.fenix.app-mergeFenixBenchmarkResources-179:/values/values.xml:9599: error: resource drawable/animated_splash_screen (aka org.mozilla.fenix:drawable/animated_splash_screen) not found.
org.mozilla.fenix.app-mergeFenixBenchmarkResources-179:/values/values.xml:9599: error: resource drawable/animated_splash_screen (aka org.mozilla.fenix:drawable/animated_splash_screen) not found.
org.mozilla.fenix.app-mergeFenixBenchmarkResources-179:/values-night-v8/values-night-v8.xml:93: error: resource drawable/animated_splash_screen (aka org.mozilla.fenix:drawable/animated_splash_screen) not found.
org.mozilla.fenix.app-mergeFenixBenchmarkResources-179:/values-night-v8/values-night-v8.xml:93: error: resource drawable/animated_splash_screen (aka org.mozilla.fenix:drawable/animated_splash_screen) not found.
Status: RESOLVED → REOPENED
Flags: needinfo?(royang)
Resolution: FIXED → ---
Target Milestone: 117 Branch → ---
Flags: qe-verify+

Thanks, I'll investigate and re-land.

Flags: needinfo?(royang)
Status: REOPENED → RESOLVED
Closed: 7 months ago7 months ago
Flags: qe-verify+
Resolution: --- → FIXED
Target Milestone: --- → 117 Branch

Verified as fixed on the latest Nightly (117.0a1) from 19th of July 2023.
Device used: Google Pixel 7 Pro (Android 14)

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Regressions: 1844261
Depends on: 1844386

(In reply to Roger Yang [:royang] from comment #0)

Add animated splash screen to first run users.

Clarification from slack discussion, to answer a question that came up in my mind when I filed a related bug:
This animation is actually intended to play (and does play) on every launch of the app. It's just a bit longer for first run.

Comment on attachment 9344437 [details] [review]
[mozilla-mobile/firefox-android] Bug 1842890 - Add splash screen animation (#2895)

Beta/Release Uplift Approval Request

  • User impact if declined: No animated splash screen
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is a change only for splash screen animation.
  • String changes made/needed:
  • Is Android affected?: Yes
Attachment #9344437 - Flags: approval-mozilla-beta?
Comment on attachment 9344437 [details] [review]
[mozilla-mobile/firefox-android] Bug 1842890 - Add splash screen animation (#2895)

Approved for Mobile 116.0b8
Attachment #9344437 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9344437 - Flags: approval-mozilla-beta+
Comment on attachment 9344944 [details] [review]
[mozilla-mobile/firefox-android] Bug 1842890 - Add splash screen animation (backport #2895) (#2934)

switching flag on the backport
Attachment #9344944 - Flags: approval-mozilla-beta+
Status: VERIFIED → RESOLVED
Closed: 7 months ago7 months ago
Flags: qe-verify+

Verified as fixed on the latest Beta 116.0b8.
The splash screen animation is present on devices with Android 12 and above.
Devices used:

  • Oppo Find X5 (Android 13).
  • Samsung Galaxy S22 Ultra (Android 13).

Marking the ticket as verified for 116 as well.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.