Closed Bug 1843707 Opened 5 months ago Closed 3 months ago

From field in message compose is too narrow

Categories

(Thunderbird :: Message Compose Window, defect)

Thunderbird 115
defect

Tracking

(thunderbird_esr102 unaffected, thunderbird_esr115 fixed)

RESOLVED FIXED
118 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird_esr115 --- fixed

People

(Reporter: michal, Assigned: Paenglab)

References

Details

(Keywords: regression)

Attachments

(3 files)

Steps to reproduce:

Created new message. Edited "from" field and entered custom email address.

Actual results:

"From" field is too narrow, I can't tell which address is there.

Expected results:

Field should be wide enough to read it's value.

Emilio, I think, this is a new-flex issue. I looked at this but didn't find a solution. Maybe you know how to fix this?

To see this you can click on the dropdown arrow and choose "Customize From Address...".

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(emilio)

So this is because you're replacing the label-box by an <input>, and the <input> doesn't size to its contents.

Do you know what was the pre-xul behavior? Any reason why this isn't just flex: 1 auto? I think that makes the menulist take all the available space and should fix this.

Flags: needinfo?(emilio) → needinfo?(richard.marti)

(In reply to Emilio Cobos Álvarez (:emilio) from comment #3)

So this is because you're replacing the label-box by an <input>, and the <input> doesn't size to its contents.

Do you know what was the pre-xul behavior? Any reason why this isn't just flex: 1 auto? I think that makes the menulist take all the available space and should fix this.

Many thanks, this fixes the issue. The pre-xul behaviour was like with the fix: the menulist uses the whole available width. In bug 1817302 this was changed to use only the width of the content which probably ended in this issue.

Now I need to look if I can fix this and also the different position of the dropmarker when changing to the input mode.

Flags: needinfo?(richard.marti)
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Duplicate of this bug: 1847132
Target Milestone: --- → 118 Branch

Pushed by elizabeth@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/6faeed02e049
Make the customize from address input as wide as the menulist text. r=elizabeth

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED

Comment on attachment 9346357 [details]
Bug 1843707 - Make the customize from address input as wide as the menulist text. r=#thunderbird-front-end-reviewers

[Approval Request Comment]
User impact if declined: in composer when changing the from address to editable it shrinks
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9346357 - Flags: approval-comm-esr115?

Comment on attachment 9346357 [details]
Bug 1843707 - Make the customize from address input as wide as the menulist text. r=#thunderbird-front-end-reviewers

[Triage Comment]
Approved for esr115

Attachment #9346357 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.