need a GUI for the preference browser.block.target_new_window

VERIFIED DUPLICATE of bug 78037

Status

SeaMonkey
Preferences
--
enhancement
VERIFIED DUPLICATE of bug 78037
16 years ago
14 years ago

People

(Reporter: Jim Tuttle, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021123
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021123

Some component of Netscape7, Phoenix, or some add-in is changing the "hidden"
preference "browser.block.target_new_window" to "true".  This preference is
"false" by default, but there is no GUI to change it back.

I don't know how it's getting changed.  Trust me - I've tried to nail it down. 
But, it's happened on at least two occasions, forcing me to edit prefs.js by
hand (not my "preference", pun intended).

Please consider adding a GUI interface to this preference, or even dropping it
completely.

Reproducible: Sometimes

Steps to Reproduce:

Actual Results:  
When the preference has been mysteriously set to false, links w/ a
target="_blank" do not spawn a new window.  This is the expected result w/ the
preference set this way.

Expected Results:  
Mozilla did the right thing.  I just wish it wouldn't honor this preference, or
if it must, provide a GUI for it.

I originally filed this as bug 172202
(http://bugzilla.mozilla.org/show_bug.cgi?id=172202)

Comment 1

16 years ago
See bug 78037 comment 7, unfortuanly this was backed out until bug 64560 is
fixed:-( As a workaround put user_pref("browser.block.target_new_window",
false); into user.js, properties in this file should never be overwritten by
Mozilla. BTW, do not share a profile between Mozilla and NS, this will give you
trouble.


*** This bug has been marked as a duplicate of 78037 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.