Closed Bug 1844263 Opened 1 year ago Closed 11 months ago

Visual indicator for focused message that is not selected missing in Cards View

Categories

(Thunderbird :: Mail Window Front End, defect)

Thunderbird 117
defect

Tracking

(thunderbird_esr115? fixed, thunderbird118? fixed)

RESOLVED FIXED
119 Branch
Tracking Status
thunderbird_esr115 ? fixed
thunderbird118 ? fixed

People

(Reporter: elijmitchell, Assigned: aleca)

Details

Attachments

(1 file)

In Cards View in the message list, if you select a message and then right click on a different message, the UI does not visually indicate that the second message has the focus. The context menu that opens is for the second/focused message, not the selected message.

In Table View, there is a clear indication on right click which message is focused and which message is selected. The selected message has a different background. The focused message is dashed.

It looks like all that is missing is a background and border on the focused item that is not selected. This is only missing on Cards View. Bring the styling for that item from Table View into Cards View.

Assignee: nobody → elizabeth
Assignee: elizabeth → alessandro
Status: NEW → ASSIGNED
Target Milestone: --- → 119 Branch

Pushed by solange@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/0bc9ec588359
Show temporary context selection state also for the cards row. r=elizabeth

Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED

Comment on attachment 9352275 [details]
Bug 1844263 - Show temporary context selection state also for the cards row. r=elizabeth

[Triage Comment]
Approved for beta (so we can get this sooner to 115)

Attachment #9352275 - Flags: approval-comm-beta+

Comment on attachment 9352275 [details]
Bug 1844263 - Show temporary context selection state also for the cards row. r=elizabeth

[Approval Request Comment]
Regression caused by (bug #): -
User impact if declined: No visual representation of the temporary selection in cards view if the user right clicks on a non selected message.
Testing completed (on c-c, etc.): on c-c and beta
Risk to taking this patch (and alternatives if risky): very low

Attachment #9352275 - Flags: approval-comm-esr115?

Comment on attachment 9352275 [details]
Bug 1844263 - Show temporary context selection state also for the cards row. r=elizabeth

[Triage Comment]
Approved for esr115

Attachment #9352275 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: