Closed Bug 1844729 Opened 8 months ago Closed 5 months ago

TB 115: Event Editor Dialog Description Text Field Resizing

Categories

(Calendar :: General, defect, P2)

Thunderbird 115

Tracking

(thunderbird_esr115+ fixed)

RESOLVED FIXED
120 Branch
Tracking Status
thunderbird_esr115 + fixed

People

(Reporter: mails.bugzilla.mozilla.org, Assigned: vineet)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/114.0.0.0 Safari/537.36

Steps to reproduce:

In the calendar component, I opened an event's editor dialog and resized it because he description field was to small to display the whole text.

Actual results:

The description text field resizes horizontally, but not vertically, leaving lots of empty, unused space in the dialog while the user still is not able to see much of the description text. (See screenshot.)

Expected results:

The description text field should resize to utilize the available space and to allow the user to see more of the description if she increases the dialog size.

Needs gentle calendar love

Component: Untriaged → General
Product: Thunderbird → Calendar

Needs gentle calendar love

Vineet, can you try to make these calendar dialog text areas behave a bit nicer?
These dialogs are an old crusty mess so we're gonna rebuild them next year, but for now maybe allowing the text area to resize alongside the dialog container should be doable with some CSS flex attributes.

Assignee: nobody → vineet
Status: UNCONFIRMED → NEW
Ever confirmed: true

This is one of the many downfalls of the flexbox transition that happened in toolkit.
Marking this for a potential 115 uplift if it's something we can fix easily.

Severity: -- → N/A
Priority: -- → P2
Status: NEW → ASSIGNED

I guess this is the same as bug 1854137?

Blocks: 1821304
Keywords: regression
Attachment #9349524 - Attachment description: WIP: Bug 1844729 - Event Description resizing to fill space of Event Summary Dialog and Attendee List correctly resizing when list is large. → Bug 1844729 - Event Description resizing to fill space of Event Summary Dialog and Attendee List correctly resizing when list is large. r=#thunderbird-reviewers
Duplicate of this bug: 1854137
Target Milestone: --- → 120 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/df0d521eabfa
Event Description resizing to fill space of Event Summary Dialog and Attendee List correctly resizing when list is large. r=aleca,freaktechnik

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED

Please request uplift to 115.

Duplicate of this bug: 1860842
Duplicate of this bug: 1861251
Flags: needinfo?(vineet)
Flags: needinfo?(vineet)

Comment on attachment 9349524 [details]
Bug 1844729 - Event Description resizing to fill space of Event Summary Dialog and Attendee List correctly resizing when list is large. r=#thunderbird-reviewers

[Approval Request Comment]
Regression caused by (bug #): -
User impact if declined: Users will not be able to scroll through an event with a large attendee list, and users will have to excessively scroll when reading a long event description
Testing completed (on c-c, etc.): Tested on c-c.
Risk to taking this patch (and alternatives if risky): -

Attachment #9349524 - Flags: approval-comm-esr115?
Duplicate of this bug: 1737138

Comment on attachment 9349524 [details]
Bug 1844729 - Event Description resizing to fill space of Event Summary Dialog and Attendee List correctly resizing when list is large. r=#thunderbird-reviewers

[Triage Comment]
Approved for esr115

Attachment #9349524 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.