Closed Bug 1844924 Opened 7 months ago Closed 6 months ago

Marking multiple mails as read only works if the first selected mail is unread

Categories

(Thunderbird :: Untriaged, defect)

Thunderbird 115
defect

Tracking

(thunderbird_esr102 unaffected)

RESOLVED DUPLICATE of bug 1850850
Tracking Status
thunderbird_esr102 --- unaffected

People

(Reporter: mieischer, Unassigned, NeedInfo)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Supernova3p])

Attachments

(1 file)

Steps to reproduce:

Select multiple mails in the following way:

  1. Click on one unread mail (which is then automatically marked as read)
  2. Shift+Click on some mail below the first one
  3. The selection now includes multiple unread messages, of which the mail at the top is unread.
  4. Press 'r' to mark the selected mails as read

Actual results:

The mails are not marked as read.

Expected results:

The mails should be marked as read.

Using the context menu to mark the mails as read works.
Explicitly marking the first mail as "unread" also allows the keyboard shortcut to work.

Version information from about:support:
Name Thunderbird
Version 115.0.1
Build-ID 20230720230327
Distributions-ID archlinux

Luna, does this reproduce for you?

Flags: needinfo?(droidbittin)

Anje, does this work for you?

Blocks: sn-msglist
Keywords: regression
Whiteboard: [Supernova3p]

Confirming issue exists on 116.0b5 on Win10.

I can't reproduce on MacOS; 117.0a1 (2023-07-21) (64-bit), MacOS 13.3.1(a)

I also don't quite follow the report; step 1 says the first mail is now automatically marked as read, but step 3 says the mail at the top is unread?

For me, on MacOS, using current Daily, the "mark as read/unread" shortcut (which is 'M' on MacOS) works fine for a block of messages.

If the first message is read, and the others unread, then the first press of M makes the first msg unread (to match the others).

If all selected messages are unread, or all are read, then M flips toggles the state for them all.

Or am I missing the point?

Step 3 should read "The selection now includes multiple unread messages, of which the mail at the top is read." (the last word must be "read" not "unread") . Sorry for the confusion.

The problematic scenario is when the first mail is already marked as read and some of the other mails are still unread. Then the keyboard shortcut doesn't mark the other mails as read.

"m" as shortcut works as expected for me. "r" does not toggle the read/unread status but only marks the mails as read.

Thanks Michael.

Note that 'R' is "mark thread as read". I don't think it's a toggle: i.e. it doesn't also mark the thread as unread.

Whereas 'M' is both "mark as read" and "mark as unread".

For me, both R & M act as above. i.e. R marks a thread as all read (regardless of how much of the thread is currently read). It doesn't mark it unread though, but I'm not sure whether it is supposed to?

To make an entire thread unread, you may first select the thread (ctrl-shift-A), and then M to mark as unread.

and to clarify:

(In reply to Michael Eischer from comment #5)

The problematic scenario is when the first mail is already marked as read and some of the other mails are still unread. Then the keyboard shortcut doesn't mark the other mails as read.

R works for me, in the above case.

i.e. I select a subset of a thread, with the first of the selected messages read, and the other selected messages unread. Then I hit R, and it marks the entire thread as read.

The R shortcut also works if I select the entire thread, with only the first message marked as read. R then marks the entire thread as read.

(In reply to Wayne Mery (:wsmwk) from comment #2)

Anje, does this work for you?

TEsting 116.0b5 on Windows OS
Select multiple mails in the following way:

Note this is tested in a folder using 'View' > 'Sort by' > 'unthreaded'

  1. Click on one unread mail (which is then automatically marked as read)
  2. Shift+Click on some mail below the first one
  3. The selection now includes multiple unread messages, of which the mail at the top is auto marked as read.
  4. Press 'r' to mark the selected mails as read

Actual results:
The mails are not marked as read.
I agree this occurs...BUT
Note: R is used to mark 'thread as read'.

Expected
As I am using 'unthreaded', pressing R would not work.

If I press 'M' then this occurs:
Because first email is marked as 'Read', then all selected emails are marked as 'Unread'
Press M again and then all selected 'Unread' emails will be marked as 'Read'

Note this is tested in a folder using 'View' > 'Sort by' > 'threaded'
Top level thread is marked as 'Read'
All subthread are marked as 'Unread'

  1. Click on top level unread mail (which is then automatically marked as read)
  2. Shift+Click on last subthread email below the first one - so all thread is selected
  3. The selection now includes multiple unread messages, of which the mail at the top is auto marked as read.
  4. Press 'r' to mark the selected mails as read

Also tested selecting various emails which are not in same thread, but folder is using 'threaded' with same expected results.

Expected results:
All mails are marked as read.
Actual results:
All mails are marked as read.

Observation:
I'm seeing everything working as expected.
After using R - pressing R again does not mark all as unread - it is not a toggle - you would need to use M.
Pressing M works to toggle as read/unread regardless of whether selected emails are threaded or unthreaded.
Using R only works to mark as read if folder is using Sort by > Threaded.

I'm not seeing any bug.

Attached image tb-unread-mails.png

(In reply to Anje from comment #8)

Actual results:
The mails are not marked as read.
I agree this occurs...BUT
Note: R is used to mark 'thread as read'.

Expected
As I am using 'unthreaded', pressing R would not work.

If a single unread mail is selected, then pressing "R" reliably marks that mail as read. After all an individual mail is just a thread of size 1. I'd expect that behavior to scale to selections of multiple individual mails. That is I'd expect that pressing "r" while selecting multiple mails, effectively applies "r" to each individual mail/thread in the selection. This expectation matches the behavior in TB 102. (One could argue that it's "mark thread as read" not "mark thread(s) as read" but that would be inconsistent with other shortcuts that work on multiple mails)

However, with TB 115 in most cases (I'll get to that in a moment), pressing "r" only has an effect if the topmost mail/thread is unread/contains an unread mail. As a result, marking all currently selected mails as read either requires manually marking the first mail as unread and pressing "r", or pressing "m" twice. Neither behavior is intuitive.

To make matters more confusing, sometimes while I'm in the inbox folder, pressing "r" seems to be applied to individual mails a expected. However, this is coupled with the effect that pressing "m" now applies to each mail individually. That is, if some mails are read and some unread, then the status of each mail is toggled individually. Switching to a different folder returns to the behavior that each mail in the selection is consistently set to read / unread and then the toggling applies to each selected mail the same way.

So I guess I'll have to amend the initial report again (sorry):

Steps to reproduce:

Switch to a folder (not the Inbox !) that is set to threaded. Then select mails that belong to different independent threads. That is, for my scenario just grab 2 or 3 independent mails from different threads (or simpler: just 3 individual mails without any threads). Make sure that all these mails are unread. Then clicking on the first of these mails marks that mail as read. Extend the selection to include all mails.

The resulting state is shown in tb-unread-mails.png . Now, pressing "r" doesn't have any effect.

After manually marking the first mail as unread such that all mails are unread (while keeping the selection), pressing "r" marks all mails as read.

Expected Behavior:

I can select a random set of mails, press "r" and afterwards each selected mail/thread is marked as read, without any regard to the previous status of the selected mails. While in the unthreaded view, each mail should be treated as a thread of size 1, such that the shortcut also works there.

Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Duplicate of bug: 1850850
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.