scrollbars on list boxes get painted wrong when mouse goes over them

RESOLVED DUPLICATE of bug 183518

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 183518
15 years ago
15 years ago

People

(Reporter: Raul Acevedo, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a; MultiZilla v1.1.32 final) Gecko/20021209
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a; MultiZilla v1.1.32 final) Gecko/20021209

When I have a list box with a scrollbar, the scrollbar gets a bizarre look ---
it gets painted incorrectly bascally --- when the mouse goes over it.  You don't
have to scroll.

Reproducible: Always

Steps to Reproduce:
1.Go to the Query Bugs URL for Bugzilla.
2.Move mouse over any scrollbar.
3.

Actual Results:  
Scrollbars looked weird.

Expected Results:  
Nothing, just keep scrollbars painted correctly.

Red Hat 8.0 with latest patches, using Mozilla 1.3a nightly RPMs from 12/9/2002
(mozilla-1.3a-2002120909_trunk_rh8_gtk2).  Latest MultiZilla.  Modern theme.
Worksforme, linux trunk build 2002-12-09-22 (modern theme, no multizilla)....  A
screenshot showing the rendering you see would be nice.
(Reporter)

Comment 2

15 years ago
Created attachment 108860 [details]
Screenshot of bad scrollbars

The Product, Component, Version, Target, Status, and OS scrollbars are wrong. 
(I put the mouse over them.)  The Severity scrollbar is half-drawn; I didn't
put the mouse over it, it just happened to be drawn that way.
Um... why are you getting themed scrollbars there instead of the standard gtk
ones?  Do you have XBL form controls turned on or something?
(Reporter)

Comment 4

15 years ago
I have no idea.  All I did was install the RPMs, remove my ~/.mozilla directory,
and run Mozilla.  The same scrollbar problem happens with Classic theme and no
MultiZilla.
(Reporter)

Comment 5

15 years ago
Ok, just tried this again.  It apparently depends on my gtk theme... if I use
the standard Red Hat Bluecurve theme, they look fine.  If I use "fishing the
sky" or "gnububble", they mess up.

I'm now using Mozilla 1.3b, the gtk2_xft RPMs.
cc'ing blizzard, could be a gtk2 issue per last comment

Actually, I can reproduce it too, on the query page. with the lighthouseblue gtk
theme.
Blocks: 92033

Comment 7

15 years ago

*** This bug has been marked as a duplicate of 183518 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.