Closed Bug 184707 Opened 22 years ago Closed 21 years ago

Tab group bookmarks / home groups should overwrite single tabs.

Categories

(SeaMonkey :: Tabbed Browser, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jasonb, Assigned: jag+mozilla)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021210

This is a "meta" bug in the sense that it's a superset of bug 159104 and bug
184660.  Each of those ask for a specific case in which a single tab should be
overwritten by a tab group bookmark or by a Home page that's been set to a tab
group.

I believe that neither one of those goes far enough and that a single tab,
regardless of its content, should always be overwritten by any tab group
bookmark or Home page that's been defined as a group of tabs.

The existence of a browser window with a single tab open should be an exception
to the current "always append" behaviour of tab groups that was introduced way
back in bug 134800.  (And which is still being "questioned" by bug 153016, bug
158365, and bug 159266 - although all 3 of those would seem to not have a
problem with the one specific change addressed by overwriting a single tab.)

Fixing this bug would fix bug 159104 and bug 184660.

Reproducible: Always

Steps to Reproduce:
Depends on: 159104, 184660
Blocks: 188329
Note the progress on bug 203960.  If it is finally resolved as FIXED, it will
also fix this bug.  (Currently, this bug is "fixed at the moment" because of it.)
Depends on: 203960
Fixed by fix for bug 203960.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.