Closed Bug 1847441 Opened 11 months ago Closed 11 months ago

Show separators for all column headers

Categories

(Thunderbird :: Mail Window Front End, enhancement, P3)

Thunderbird 117
enhancement

Tracking

(thunderbird_esr115? fixed, thunderbird118? fixed)

RESOLVED FIXED
119 Branch
Tracking Status
thunderbird_esr115 ? fixed
thunderbird118 ? fixed

People

(Reporter: anjeyelf, Assigned: aleca)

Details

(Keywords: triaged, ux-control)

Attachments

(2 files, 1 obsolete file)

Windows 10
beta 117.0b1

Column headers in Thread Pane
I have the following column headers from left to right.

Thread, Starred, Attachments, Read Status, From, Subject, Date, Size, 'Select columns to display' icon

However, there are many missing column separators which means it looks incorrect and inconsistant and not very easy to move columns which is necessary as the default set is not desirable.
Instead I see this.

Thread Starred Attachments Read Status From | Subject | Date | Size 'Select columns to display' icon

I have indicated a separator using |, but it only displays between the following.

  • From | Subject
  • Subject | Date
  • Date | Size

There is nothing between:

  • Thread Starred
  • Starred Attachments
  • Attachments Read Status
  • Read Status From
  • Size 'Select columns to display' icon

Request all column headers have a separator between columns.

Only the columns that are resizable have a separator to visually indicate which can be modified.
All other columns are static and can't be resized.

What is the purpose of that separator?
Is that single line really that important or just noise that is not needed? (This is not a passive aggressive question, it's a legit curiosity)
Wouldn't having separators for each column create a more cluttered UI and mislead users in thinking that they can resize those columns?

Flags: needinfo?(anjeyelf)

(In reply to Alessandro Castellani [:aleca] from comment #1)

Only the columns that are resizable have a separator to visually indicate which can be modified.
All other columns are static and can't be resized.

I never thouhgt of the separator as only a means to resize a column in versions up to and including 102*, but it's useful information on why a column has no separator in 115*.
The lack of separator on columns that currently cannot be resized is a new concept just introduced.

What is the purpose of that separator?
Is that single line really that important or just noise that is not needed? (This is not a passive aggressive question, it's a legit curiosity)

Yes, it's very important.

  1. If sight is poor, those separators help to differentiate start and stop of a column.
  2. Purely visual impact - it's irritating and I mean really irritating. I've tried to ignore it - you know get used to something new, but it's impossible because it's unbalanced. I've got 102* running as well and it's visually much better to see something that looks unified. Your eyes are not constantly drawn to it's attention. But supernova is Part a list and other parts columns - it jumps out at you- it is serious noise. This is also the sort of thing which can effect people with some spectrums of autism. They prefer the correct alignment of objects.
  3. It acts as an Aid when moving of columns to prefered positions. The line helps you to see where to drop it.

Wouldn't having separators for each column create a more cluttered UI and mislead users in thinking that they can resize those columns?

It's not cluttered and never has been. Everything had a purpose.

  1. resizing - Good point - improve usability so design is more inclusive for all abilities.
    What's wrong with increasing the column width if you want to space icons/columns out a bit more.? Obviously there needs to be a minimum width. I notice the supernova design does set those column much thinner than in previous designs because the separator has been removed.
    However, not everyone has a steady hand. If you put icons close together, it's possible to cause useability issues for some people.
    That is actually a very good arguement for including the separator and allowing people to resize the width to allow more space between icons.
    That is something which could be seen as an improvement both visually and effectively makes the design more inclusive for those less abled.
Flags: needinfo?(anjeyelf)
Severity: -- → S4
Type: defect → enhancement
Keywords: triaged, ux-control
Priority: -- → P3
Summary: Some column headers have no separators and others do - inconsistant → Show separators for all column headers
Attached image Separators or not.png (obsolete) —

It acts as an Aid when moving of columns to prefered positions. The line helps you to see where to drop it.

I think this is a valid point that might make us implement those separators.
Even tho columns move away when dragging so the positioning is pretty obvious.

We definitely don't want to allow resizing the icon columns because that can result into a very messy columns sizing, and 102 didn't allow that either.
I'll keep this request for enhancement open and see if we get any more reports.

I did a quick visual test and to me having all those separators so close alongside icons is visually annoying and useless.
Micah, what do you think?

Flags: needinfo?(micah)
Attached image Separators or not.png

Larger resolution

Attachment #9348250 - Attachment is obsolete: true

Using 102.14.0 I see no separators, so may be they have dropped off 102 also or it is theme based? Hadn't really noticed them missing as see the pointer change as it runs over a resizeable column boundary but a separator would save scanning with the pointer to see if a column is resizeable.

I agree and support Anje proposal to keep separators for all columns including the icons ones. It is much less tiring for the brain and help focus.

(In reply to Alessandro Castellani [:aleca] from comment #3)

Created attachment 9348250 [details]
Separators or not.png

It acts as an Aid when moving of columns to prefered positions. The line helps you to see where to drop it.

I think this is a valid point that might make us implement those separators.
Even tho columns move away when dragging so the positioning is pretty obvious.

I would add that (at least for me) the separators better indicate that these columns allow for dragging and positioning.

I did a quick visual test and to me having all those separators so close alongside icons is visually annoying and useless.
Micah, what do you think?

It does feel a little weird to me that there is a separator before and after every text column except the first and last ones because of the icon positioning. Not having the separators between them give me the impression that the icons are not position-able and/or they move position as a group. I think I agree with adding the separators here. While I do think they are visually more heavy, I also think that it brings better consistency and a slightly better understanding of their ability to be positioned.

Flags: needinfo?(micah)

All right, the designer has spoken, I'll take care of this.

Assignee: nobody → alessandro
Status: NEW → ASSIGNED
Target Milestone: --- → 119 Branch

Pushed by kaie@kuix.de:
https://hg.mozilla.org/comm-central/rev/0ae43dd02062
Show splitter separators for all columns in the tree-view.mjs. r=Paenglab,micahilbery

Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED

Comment on attachment 9350733 [details]
Bug 1847441 - Show splitter separators for all columns in the tree-view.mjs. r=#thunderbird-front-end-reviewers

[Approval Request Comment]
Regression caused by (bug #): -
User impact if declined: Strange visual rhythm as separators are not shown for all the columns in the message list table view
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9350733 - Flags: approval-comm-esr115?
Attachment #9350733 - Flags: approval-comm-beta?

Comment on attachment 9350733 [details]
Bug 1847441 - Show splitter separators for all columns in the tree-view.mjs. r=#thunderbird-front-end-reviewers

[Triage Comment]
Approved for beta
Approved for esr115

Attachment #9350733 - Flags: approval-comm-esr115?
Attachment #9350733 - Flags: approval-comm-esr115+
Attachment #9350733 - Flags: approval-comm-beta?
Attachment #9350733 - Flags: approval-comm-beta+

Thank you to all concerned. It looks good in 118.0b2.

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: