Closed Bug 1847446 Opened 11 months ago Closed 5 days ago

Can only sort by visible columns, unlike earlier versions

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 115
defect

Tracking

(thunderbird_esr102 unaffected, thunderbird_esr115 affected, thunderbird128 affected)

RESOLVED DUPLICATE of bug 1830262
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird_esr115 --- affected
thunderbird128 --- affected

People

(Reporter: blmatthews, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Supernova3p])

Steps to reproduce:

Have attachments, starred, subject, read status, correspondents, and date columns visible in message list. Attempt to sort by order received (my usual and preferred sort order).

Actual results:

View > Sort by > Order Received is grayed out and not selectable, as are a number of other items under Sort by.

Expected results:

Any column should be able to be sorted by, whether it's visible or not, as it was in 112 and earlier. In particular, Order Received appears to just be an integer, so adding a column for that is fairly pointless and a waste of space.

I'm running Thunderbird 115.1.0.

Came here to report the same issue - of course you can't sort by columns that are not shown by clicking on the column header, but why disable sorting by those via the menu all of a sudden when it was perfectly possible in TB 102?

Blocks: sn-msglist
Component: Untriaged → Folder and Message Lists
Keywords: regression
Whiteboard: [Supernova3p]

Very annoying. Have to enable the column view, then sort by it, then disable the column again.
No reason to have to have the column visible to be able to sort the list by it.

See Also: → 1830262
Duplicate of this bug: 1899302
Severity: -- → S3
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Closed: 5 days ago
Duplicate of bug: 1830262
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.