Closed Bug 1848677 Opened 10 months ago Closed 9 months ago

[Kiosk] Make window fullscreen immediately after start

Categories

(Core :: Widget: Gtk, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
119 Branch
Tracking Status
firefox119 --- fixed

People

(Reporter: stransky, Assigned: stransky)

References

Details

Attachments

(3 files)

In kiosk mode we want the window to be fullscreened immediately after start to avoid startup delay.

Flags: needinfo?(stransky)
Depends on: 1848599

It's possible that kiosk mode starts in normal size under Wayland - so we should create it fullscreen immediately.

Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/49c16861054d
Don't remove --kiosk command line argument from startup args r=emilio
https://hg.mozilla.org/integration/autoland/rev/6babea3253fc
Don't fiddle with titlebar settins of kiosk nsWindow r=emilio
https://hg.mozilla.org/integration/autoland/rev/73c86543bf82
Create kiosk nsWindow as fullscreen r=emilio
Duplicate of this bug: 1837403
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 119 Branch
Flags: needinfo?(stransky)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: