If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Attaching multiple files to an email actually adds a folder index/directory

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
VERIFIED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Ian Nartowicz, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021210
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021210

When I ctrl-click or shift-click to attach multiple files to an email, the
attachment becomes a folder (see attachment).  In the received email, the folder
shows as being a list of all the files in the folder.

Reproducible: Always

Steps to Reproduce:
1. Compose email
2. Shift-click or ctrl-click to attach multiple files
3. Send file to yourself

Actual Results:  
One attachment appears, with the name of the folder, and a folder icom.
The received email shows a text attachment with a list of every file in the folder.

Expected Results:  
The selected files should be attached to the email

I discussed this in bug 43015 and was requested to raise a separate bug.
(Reporter)

Comment 1

15 years ago
Created attachment 109044 [details]
Attaching the "folder"
(Reporter)

Comment 2

15 years ago
Created attachment 109045 [details]
Contents of the attachment

Updated

15 years ago
QA Contact: olgam → stephend
*** Bug 185759 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
Can anyone find our with which build this stared?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

15 years ago
Severity is harder than "normal", it is as least "critical"
(Reporter)

Comment 6

15 years ago
Rainer, it may always have been like this.  Until sometime around the end of
September 2002, it wasn't possible to do multiple attachments at all.  Seth
produced a patch for Win32 to attach multiple files at once, but I suspect that
Win98 never worked correctly?  Maybe Seth could comment if he knows whether it
ever worked right in Win98.  See bug #43015 and bug #121122 for the full history.

Comment 7

15 years ago
Ian, please have a look to Bug 185759!
I used this function (attatch more than 1 file) in several builds  without any
problem.

Comment 8

15 years ago
A fist test:

No Problems in
Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.2b) Gecko/20021103


Problems  in
Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.3a) Gecko/20021122

Comment 9

15 years ago
Worked with V1.2.1
Not working with new V1.3a

Comment 10

15 years ago
*** Bug 188096 has been marked as a duplicate of this bug. ***
Adding 'directory' to the summary to enable improved bugzilla searches.
Summary: Attaching multiple files to an email actually adds a folder index → Attaching multiple files to an email actually adds a folder index/directory

Comment 12

15 years ago
Today I tried again and had _no_ problem with
Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.3b) Gecko/20030105

I have no idea concerning the reason.

Comment 13

15 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20030106

Seems to be solved into my version too!

Comment 14

15 years ago
I will watch that "progress by chance" for more or less 2 weeks; if the bug will
not have reappeared, I will make the bug WFM
Marking worksforme.  This way, only if we see it again, can we reopen it.

This is better for tracking; having 'fixed' (worksforme, actually, since we
can't point to a single fix) bugs lying around as open is distracting to the
triage process.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 16

15 years ago
WFM 2003010608 and 2003010808.  Weird.
Status: RESOLVED → VERIFIED

Comment 17

15 years ago
I had Problems in 1.3a:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021212

No Problems in 1.3b:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030210

THX!-)

Comment 18

14 years ago
*** Bug 188437 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.