hover bug with pseudo complex layout

RESOLVED WORKSFORME

Status

()

Core
Layout: R & A Pos
P3
normal
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: glandium, Unassigned)

Tracking

({pp, testcase})

Trunk
Future
x86
Linux
pp, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

User-Agent:       Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021208 Debian/1.2.7-5
Build Identifier: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021208 Debian/1.2.7-5

(part of a split of bug #183913)

in the url given, when hovering the link, the span correctly disappears,
but doesn't reappear when mouse stops being on the link. If the display
attribute is inverted (ie. none for a .plop and block for a:hover .plop), the
span doesn't appear at all.

The same effect is seen when playing with visibility instead of display.

Note: adding top: 0px; left: 0px for positionning the span shows a strange thing
(see http://glandium.org/test2.html )

Note 2: it is not a general hover bug, since it works fine with other layouts.


Reproducible: Always

Steps to Reproduce:
Hmmm. WFM (the span disappears when mousing over the link and reappears when the
mouse moves off it) in the latest Windows trunk build.

Comment 2

15 years ago
confirmed with linux trunk build 20021210.

covering the area with another window and then removing the other window induces
Mozilla to redraw it properly.  If the box is displayed, and you partially over
it, that part of the box is not redrawn.

also, if the image src= points at a real image, then test.html renders the same
as test2.html.

marking NEW
==> R&A Pos  (Views?)
Assignee: other → position
Status: UNCONFIRMED → NEW
Component: Layout → Layout: R & A Pos
Ever confirmed: true
Keywords: testcase

Comment 3

15 years ago
this is platform specific.... only reproducible on Linux.
Keywords: pp
Priority: -- → P3
Looks like a combination of the incorrect containing block thing with rel-pos
inlines (for test.html) and the incorrect painting of the overflow area of such
inlines (bug 79315) (for test2.html).
Keywords: pp
Priority: P3 → --
Keywords: pp
Priority: -- → P3

Comment 5

15 years ago
WFM on Linux trunk build 20021215 (compiled with Gtk+ 2 support).

Updated

15 years ago
Target Milestone: --- → Future
WFM on latest Mozilla builds on Linux with GTK2

(note that testcases moved to 
http://glandium.org/bugs/mozilla-184899.html
and
http://glandium.org/bugs/mozilla-184899-2.html )
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.