absolutely positioned boxes in relatively positioned inline bug + hover bug

RESOLVED DUPLICATE of bug 184897

Status

()

Core
Layout
P3
normal
RESOLVED DUPLICATE of bug 184897
15 years ago
15 years ago

People

(Reporter: glandium, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021204 Debian/1.2.7-4
Build Identifier: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021204 Debian/1.2.7-4

On the page http://glandium.org/test.html there are 2 bugs :

the first one, (i think) is about the positioning of the span, which should be
just under the text (ie. no margins)

the second one is that when hovering the link, the span correctly disappears,
but doesn't reappear when mouse stops being on the link. If the display
attribute is inverted (ie. none for a .plop and block for a:hover .plop), the
span doesn't appear at all.

The same effect is seen when playing with visibility instead of display.

Note: adding top: 0px; left: 0px for positionning the span shows a strange thing
(see http://glandium.org/test2.html )

Reproducible: Always

Steps to Reproduce:
Please file separate bugs for each problem...

This is all likely caused by the mess that is rel-pos-inlines as containing
blocks.... :(

Comment 2

15 years ago
assuming this bug is now for the margin issue and bug 184899 is for the hover
problem, this bug is WFM with linux trunk build 20021210 although 1.2.1 displays
as you have described.
(Reporter)

Comment 3

15 years ago
Oops, I also opened an other bug for the margin issue : bug 184897, sorry

Comment 4

15 years ago
so what is this bug for?
(Reporter)

Comment 5

15 years ago
right now, nothing, since both parts have been resubmitted (bug 184897 and bug
184899).; sorry again.
I don't know if i should change resolution to invalid or mark it as a duplicate
of one of the resubmitted bugs...

Comment 6

15 years ago
*** Bug 184897 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Priority: -- → P3

Comment 7

15 years ago
ok... after all the duping I'm gonna reask the question posed in comment 4...
"so what is this bug for?"

Comment 8

15 years ago
this bug is for the margin issue:
> the first one, (i think) is about the positioning of the span, which should be
> just under the text (ie. no margins)
That would be much clearer if things were marked duplicate in the other direction.

*** This bug has been marked as a duplicate of 184897 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.