Closed Bug 1849000 Opened 11 months ago Closed 11 months ago

Make the cards view and vertical layout default for new profiles

Categories

(Thunderbird :: Mail Window Front End, task, P1)

Tracking

(thunderbird_esr115? fixed, thunderbird118? fixed)

RESOLVED FIXED
119 Branch
Tracking Status
thunderbird_esr115 ? fixed
thunderbird118 ? fixed

People

(Reporter: aleca, Assigned: aleca)

References

Details

Attachments

(1 file)

In the past month we fixed a lot of annoying list view issues and improved the vertical layout.
It's time to make the cards view and vertical layout the default state, but only for new profiles, with a migration to guarantee existing users won't get their settings changed.

  • New empty profiles should get the Vertical Layout and Cards View by default
  • Existing profiles shouldn't be affected
  • All tests have been updated to ensure they work with the new defaults, except those that need to test specific table view features
Attachment #9349292 - Attachment description: Bug 1849000 - Make the cards view and vertical layout the default for new profiles. r=darktrojan → Bug 1849000 - Make the cards view and vertical layout the default for new profiles. r=john.bieling
Status: NEW → ASSIGNED
Target Milestone: --- → 119 Branch

Pushed by kaie@kuix.de:
https://hg.mozilla.org/comm-central/rev/913b03d272b8
Make the cards view and vertical layout the default for new profiles. r=john.bieling

Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED

Comment on attachment 9349292 [details]
Bug 1849000 - Make the cards view and vertical layout the default for new profiles. r=darktrojan

[Approval Request Comment]
Regression caused by (bug #): -
User impact if declined: New users will not see the new cards view and vertical layout as default
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low for existing users as the patch migrates the current prefs and only shows the cards view and vertical layout to new profiles

Attachment #9349292 - Attachment description: Bug 1849000 - Make the cards view and vertical layout the default for new profiles. r=john.bieling → Bug 1849000 - Make the cards view and vertical layout the default for new profiles. r=darktrojan
Attachment #9349292 - Flags: approval-comm-esr115?
Attachment #9349292 - Flags: approval-comm-beta?

Comment on attachment 9349292 [details]
Bug 1849000 - Make the cards view and vertical layout the default for new profiles. r=darktrojan

[Triage Comment]
Approved for beta

Attachment #9349292 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9349292 [details]
Bug 1849000 - Make the cards view and vertical layout the default for new profiles. r=darktrojan

[Triage Comment]
Approved for esr115

Attachment #9349292 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: