Closed Bug 1850221 Opened 6 months ago Closed 5 months ago

Request permissions doesn't prompt in options

Categories

(Fenix :: WebExtensions, enhancement, P3)

Firefox 118
All
Android
enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1810047

People

(Reporter: regseb, Unassigned)

Details

Attachments

(1 file)

Attached file permissions.zip

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/116.0

Steps to reproduce:

  • Unzip permissions.zip
  • Load it in Firefox Android
  • Go to options page of extension
  • Click "Request permission" button

Actual results:

Nothing.

Expected results:

Firefox prompts permission.

The severity field is not set for this bug.
:amejia, could you have a look please?

For more information, please visit BugBot documentation.

Flags: needinfo?(amejiamarmol)
Severity: -- → S3
Type: defect → enhancement
Flags: needinfo?(amejiamarmol)
Priority: -- → P3

Firefox requires Manifest V3 extensions to request the <all_urls> permission at runtime:
https://stackoverflow.com/questions/76083327/firefox-extension-manifest-v3-request-permission-to-access-your-data-for-all

As a result of this bug, <all_urls> seems impossible to use from Android Manifest V3. This affects IPvFoo.

This is because the UI hasn't been implemented yet, see Bug 1810047 (also, sorry about that).

Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Duplicate of bug: 1810047
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.