Last Comment Bug 185112 - mozilla 1.2.1 works for a while, then creates lots of pipes and dies
: mozilla 1.2.1 works for a while, then creates lots of pipes and dies
Status: RESOLVED WORKSFORME
: crash
Product: SeaMonkey
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 Linux
: -- critical (vote)
: ---
Assigned To: Asa Dotzler [:asa]
: Asa Dotzler [:asa]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-12 15:37 PST by Arcterex
Modified: 2004-11-22 17:25 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Arcterex 2002-12-12 15:37:35 PST
User-Agent:       Opera/6.03 (Linux 2.4.19-gentoo-r10 i686; U)  [en]
Build Identifier: mozilla 1.2.1+xft+gentoo patches

I emerged mozilla 1.2.1-r1 on the gentoo build system and it all worked 
dandy, I can quit and restart fine.  After some time (a day, an hour, a few 
quits and restarts?) mozilla stops working properly, and segfaults on
startup.   It will sit there for a while, using 100% cpu (my system-monitor 
is pegged, but the system is still responsive) for a loooong time, until it 
crashes with a segfault.

Using strace and lsof it looks like mozilla is spawning off pipes like 
there is no tomorrow, until it can't do it anymore and segfaults.  While it 
is sitting there spinning an "lsof -n | grep mozilla" shows something like 
the following:

mozilla-b 2992    alan   10r   REG       33,6   299532    442240 
/usr/lib/mozilla/chrome/classic.jar
mozilla-b 2992    alan   11r   REG       33,6   678179    442169 
/usr/lib/mozilla/chrome/en-US.jar
mozilla-b 2992    alan   12r   REG       33,6     4725    442362 
/usr/lib/mozilla/chrome/en-unix.jar
mozilla-b 2992    alan   13r   REG       33,5   968442    374638 
/home/alan/.mozilla/alan/e71w41a1.slt/XUL.mfasl
mozilla-b 2992    alan   14r  FIFO        0,6              78671 pipe
mozilla-b 2992    alan   15w  FIFO        0,6              78671 pipe
mozilla-b 2992    alan   16r   REG       33,6   922727    442181 
/usr/lib/mozilla/chrome/comm.jar
mozilla-b 2992    alan   17r   REG       33,6   226476    442235 
/usr/lib/mozilla/chrome/toolkit.jar
mozilla-b 2992    alan   18r  FIFO        0,6              78672 pipe
mozilla-b 2992    alan   19w  FIFO        0,6              78672 pipe
mozilla-b 2992    alan   20r   REG       33,6    22827    442238 
/usr/lib/mozilla/chrome/US.jar
mozilla-b 2992    alan   21r   REG       33,6   108751    442368 
/usr/lib/mozilla/chrome/chatzilla.jar
mozilla-b 2992    alan   22r  FIFO        0,6              88238 pipe
mozilla-b 2992    alan   23w  FIFO        0,6              88238 pipe
mozilla-b 2992    alan   24r  FIFO        0,6              92999 pipe
mozilla-b 2992    alan   25w  FIFO        0,6              92999 pipe
mozilla-b 2992    alan   26r  FIFO        0,6              93000 pipe
mozilla-b 2992    alan   27w  FIFO        0,6              93000 pipe
mozilla-b 2992    alan   28r  FIFO        0,6              93001 pipe
mozilla-b 2992    alan   29w  FIFO        0,6              93001 pipe
mozilla-b 2992    alan   30r  FIFO        0,6              93002 pipe

The list of pipes will grow and grow until it is quite long, then boom, 
mozilla dies.

If I unmerge then remerge, it will work ok for a bit, but I obviously
don't want to do this too often!  The precompiled tarball from mozilla.org
doesn't do this of course, but it doesn't have the xft/freetype patches.  
I've tried with and without xfs running, deleted my .mozilla, and have 
deleted the font-cache files in my /usr/lib/X11/fonts/* directories.  

I know when moz starts up it does a bunch of checking for fonts and they go 
scrolling by on the console window.  I've looked for, but can't find a way 
to force it to do this again.  Maybe this can help track down the problem?


Reproducible: Always

Steps to Reproduce:
1. start mozilla
2. watch it spin
3. watch it die

Actual Results:  
segfault

Expected Results:  
to start properly

Gentoo 1.3 (gcc 3.1) on an athlon (x86)

Gentoo builds mozilla with the following patches:

mozilla-alpha-xpcom-subs-fix.patch
mozilla-1.2b-Xft-includes.patch.bz2
mozilla-1.2b-wallet.patch.bz2
mozilla-1.2b-over-the-spot.patch.bz2
mozilla-1.2b-freetype.patch.bz2
mozilla-1.2b-default-plugin-less-annoying.patch.bz2
Comment 1 Andrew Schultz 2002-12-12 20:17:42 PST
you can have it look for the fonts again by clobbering ~/.mozilla/fonts

FWIW after having Mozilla running for 3.5 hours, 
% lsof -n | grep mozilla | grep pipe | wc -l
    64

When it has this problem, try deleting the XUL.mfasl file in your profile
directory and see if that helps.

Also, try compiling without the gentoo patches.  Xft shouldn't require any extra
patches.  just "./configure --enable-xft".  Freetype is enabled by default.
Comment 2 Arcterex 2002-12-13 11:20:58 PST
I've played around with this a bit more and have some more info.  Mozilla by
itself works fine, it is only when galeon 1.2.7 is run that it breaks.  I ran it
all morning, quitting and restarting several times, watching the number of pipes
created carefully with lsof.  The number averaged about 48, but never got higher
than 90 or so.

I then ran a newly compiled galeon 1.2.7 (again, the gentoo ebuild) and it too
worked just fine.  I quit the program and then started mozilla, and it spun for
a while, creating up to about 6000 pipes, then crashed.  It has had the same
behaviour since.

I removed ~/.fonts.cache-1 (which after galeon was run was a 0 byte file) and
.mozilla/fonts, neither of which were re-created properly while mozilla was
spinning.  Removing .mozilla had no affect either, but it and the files appreg
and pluginreg.dat were re-created while it was creating pipes.

I'm not sure what to do with this now though, is it a mozilla bug or a galeon
bug?  Obviously galeon is doing *something* to cause mozilla to spin and crash,
but the fact that it affects mozilla (ie: when moz is run by itself) is very
strange.
Comment 3 Christophe Fergeau 2002-12-15 13:11:48 PST
Can you check if this is related to bug #99229 on bugzilla.gnome.org
This looks very similar
Comment 4 Arcterex 2002-12-15 15:00:32 PST
Nope, I don't think it is.  In that one it looks like it is a bug in the window
creation (or something).  In mine mozilla is rendered useless, and galeon cannot
even load the mozilla widget, and doesn't spawn any windows, only pipes :)
Comment 5 Arcterex 2002-12-15 15:59:14 PST
My mistake.  The workaround noted in that bug works (making
components/compreg.dat readonly).
Comment 6 Kai Lahmann (is there, where MNG is) 2003-05-31 10:36:12 PDT
does the problem still exist?
Comment 7 Arcterex 2003-06-08 22:44:31 PDT
This actually hasn't happened in quite a while.  Currently on 1.3.x on gentoo linux.
Comment 8 Kai Lahmann (is there, where MNG is) 2003-06-09 03:47:05 PDT
s let's make this wfm...

Note You need to log in before you can comment on or make changes to this bug.