Closed Bug 18515 Opened 21 years ago Closed 19 years ago

Need status indication when Mark All Read takes awhile...

Categories

(MailNews Core :: Backend, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED WONTFIX
Future

People

(Reporter: laurel, Assigned: Bienvenu)

References

Details

Mark All Read needs status bar text/indicator when marking a large amount of
messages. Performance is currently horrible (see bug #17470) and in many cases
I've thought the application had hung when marking all read in a decent sized
newsgroup.

1.  Launch messenger, add a news server.
2.  Subscribe to a newsgroup with several hundred messages.
3.  Open the newsgroup, let all headers download.
4.  Message|Mark All Read.

Result:   it takes a while and there is no indication anything is happening.

Expected result:  should have status text and/or progress indicator for where we
are in the process of marking messages read.
QA Contact: lchiang → fenella
Summary: Need status indication when Mark All Read takes awhile... → Need status indication when Mark All Read takes awhile...
Assignee: phil → bienvenu
Depends on: 17470
After 17470 is fixed, the performance should be good enough that we won't need
any progress feedback. If it seems important, we can leave this bug open until
17470 is fixed, but otherwise, I'd probably just mark it a dup.
So we're not going to do it like 4.x where the status text runs down how many
headers are marked out of N headers?
see laurel's previous question
Status: NEW → ASSIGNED
Target Milestone: M20
given how slow it is to display status messages, I think not. But I'll leave it
open for a while.
Target Milestone: M20
Oh, I forgot about Laurel's point. I guess I'd prefer to wait and see (if it's
slow enough that we need progress feedback)
Target Milestone: M15
I see bug #17470 has been marked verified/fixed.  Performance testing was done
on 500 messages using 1/13 build.

Now (I'm using 1/13 afternoon builds on NT 4.0 and linux 6.0), try marking a
newsgroup read which has a couple thousand headers (like mozilla'a mail-news
group ... I really think we need a status indicator of some sort.
moving to m16
Target Milestone: M15 → M16
Cleanup work, marking M18.
Target Milestone: M16 → M18
Only after reading this bug description I found out where Mozilla hides the Mark
All Read feature. I've been very frustrated to find that it isn't in the
RMB-menu from the newsgroup (I mean in the Mail Folders list) anymore, like it
was in N4.xx.
don't think this is going to be an issue with new performance work.
Target Milestone: M18 → Future
*** Bug 81861 has been marked as a duplicate of this bug. ***
Holy Cow.. in a current linux CVS build "Mark read" suddenly takes no time at
all, instead of like before when it could take ages with many unread messages. :))))
now that we're using the outliner for the folder pane, we don't need this
anymore, I don't think.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → WONTFIX
QA Contact: fenella → laurel
*** Bug 98256 has been marked as a duplicate of this bug. ***
marking verified -- old invalid or wontfix resolutions
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.