Closed Bug 1852335 Opened 11 months ago Closed 10 months ago

Rename WebExtension popup feature and ExtensionsProcessDisabled popup feature to observer

Categories

(Fenix :: General, task, P1)

All
Android
task

Tracking

(firefox119 verified)

VERIFIED FIXED
119 Branch
Tracking Status
firefox119 --- verified

People

(Reporter: zmckenney, Assigned: zmckenney)

Details

Attachments

(2 files)

The WebExtensionsPopupFeature and the new ExtensionProcessDisabledPopupFeature are not actually "features" and should be renamed. ExtensionProcessDisabledPopupFeature is especially not a feature as it is now open and does not conform to "feature" standards.

Assignee: nobody → zmckenney
Severity: -- → N/A
Priority: -- → P1

Authored by Zac McKenney
https://github.com/mozilla-mobile/firefox-android/commit/133cd46e7a74e8b151f7a790273056644630b398
[main] Bug 1852335 - Renamed WebExtensionPopupFeature and ExtensionProcessDisabledPopupFeature to observers

Status: NEW → RESOLVED
Closed: 10 months ago
Flags: qe-verify+
Resolution: --- → FIXED
Target Milestone: --- → 119 Branch

Hello Zac,

Is QA verification needed for this issue? If so, could you please provide us with some steps to reproduce (STR) or testing scenarios?

Thank you!

Flags: needinfo?(zmckenney)

Hi, please follow the STR from https://bugzilla.mozilla.org/show_bug.cgi?id=1846979#c7. Note that with Firefox Nightly, you don't need the nimbus-cli anymore ("prerequisite section") because the process is enabled by default (or should be...). Anyway, the STR should also cover that part. Thanks!

Flags: needinfo?(zmckenney) → needinfo?(apetridean)

Verified on the latest Nightly 119.0a1 from 2023-09-14.

  • I did get the popup after crashing the extensions process 6 times consecutively.
  • Selecting “Try restarting add-ons” will restart the extensions process and it will be visible in about:processes
  • Selecting “Continue with add-ons disabled” will not restart the extensions process and it will no longer be listed in about:processes

Verified it in dark mode as well, here.
The feature was tested in details in the mentioned ticket on Beta 118.0b6 as well.

Tested devices:

  • Google Pixel 7 (Android 14).
  • Oppo Find X5 (Android 13).
  • Samsung Galaxy Tab A7 (Android 13).

Marking the ticket as verified for 119.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(apetridean)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: