Closed Bug 1846979 Opened 10 months ago Closed 8 months ago

Implement process crash UI

Categories

(Fenix :: WebExtensions, enhancement)

All
Android
enhancement

Tracking

(firefox117 wontfix, firefox118 verified, firefox119 verified)

VERIFIED FIXED
119 Branch
Tracking Status
firefox117 --- wontfix
firefox118 --- verified
firefox119 --- verified

People

(Reporter: willdurand, Assigned: zmckenney)

References

(Blocks 1 open bug)

Details

(Whiteboard: [addons-jira])

Attachments

(7 files)

Once Bug 1819737 lands, we'll have a new delegate method that will notify Fenix when a process crash has happened. When that is the case and when the process is stopped by Gecko, we'll need to show some UI to users asking them to either be "ok with continuing without extensions for the rest of the session" OR "try to restart" the extensions process again (which might cause it to crash again).

See Also: → 1847088
Depends on: 1848426
No longer depends on: 1819737
Depends on: 1819737
No longer depends on: 1848426
Keywords: leave-open
Attached image updated ux spec

Here is the updated spec from UX. That's what we want to ship.

Authored by Zac McKenney
https://github.com/mozilla-mobile/firefox-android/commit/0cc85ed36c62b5ea3516b8c96f3a01043cebc3c9
[main] Bug 1846979 - Add extensions process crash dialog strings.

Keywords: leave-open

Authored by Zac McKenney
https://github.com/mozilla-mobile/firefox-android/commit/2c533231b6886b1359065b7adac11fa1139aa4dc
[main] Bug 1846979 - Add extensions process spawning disabled dialog

Status: NEW → RESOLVED
Closed: 9 months ago
Flags: qe-verify+
Resolution: --- → FIXED
Target Milestone: --- → 119 Branch

For QA...

Prerequisite:

The extensions process must be enabled on Firefox for Android. Currently the STR are:

  1. install nimbus-cli
  2. create a file named feature.json and add the following content into it: { "enabled": true }
  3. run: nimbus-cli --app fenix --channel nightly test-feature extensions-process ./feature.json

That command in (3) will load the experiment in fenix and that should also enable the extensions process.

You can unlock the "debug menu" in fenix by taping a few times to the Firefox logo in "Settings > About Firefox Nightly", this will add a "Nimbus Experiments" menu item, and the "extensions-process" nimbus feature should be listed there.

STR:

  1. With the extensions process enabled, install an add-on, e.g. uBlock Origin
  2. Open a new tab and go to about:processes, there should be an extensions process
  3. Open a new tab and go to about:crashextensions
  4. Reload the tab in (3) to crash the extensions process again. Repeat 4 times. At this point, the process has crashed 5 times.
  5. Reload the tab in (3) one more time

Expected: a dialog is shown (more or less like in Comment 3) and about:processes should not have any extensions process anymore

If you click "try restarting add-ons", you should expect the extensions process to be listed in about:processes again.

If you click "continue with add-ons disabled", no extensions process should be listed in about:processes.

:mixedpuppy as per the uplift request process guide (which explains why I need your approval ;-)), I'd like to nominate the PR #3472 as a candidate to backport to the 118 branch so that we have the whole UI for the experiment. Are you OK with that? Thanks!

Flags: needinfo?(mixedpuppy)

(In reply to William Durand [:willdurand] from comment #8)

:mixedpuppy as per the uplift request process guide (which explains why I need your approval ;-)), I'd like to nominate the PR #3472 as a candidate to backport to the 118 branch so that we have the whole UI for the experiment. Are you OK with that? Thanks!

approved

Flags: needinfo?(mixedpuppy)

Comment on attachment 9351800 [details] [review]
[mozilla-mobile/firefox-android] Bug 1846979 - Add extensions process spawning disabled dialog (backport #3472) (#3513)

Beta/Release Uplift Approval Request

  • User impact if declined: None.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This patch is covered by tests and has been manually verified. We'd need this patch in 118 because it adds UI in Fenix for an experiment (extensions process).
  • String changes made/needed:
  • Is Android affected?: Yes
Attachment #9351800 - Flags: approval-mozilla-beta?

Verified as Fixed. Tested on the latest Nightly for Android (119.0a1/Build #2015972707, d110b3c281+)(GV: 119.0a1-20230906214643)(AS: 119.20230906050317) based on the STR from Comment 7.

Results:

  • Crashing the extensions process 6 times consecutively will display the UI.
  • Selecting “Try restarting add-ons” will restart the extensions process and it will be visible in about:processes
  • Selecting “Continue with add-ons disabled” will not restart the extensions process and it will no longer be listed in about:processes
  • In case “Continue with add-ons disabled” has been selected, the extensions process can be restarted by restarting the browser or by disabling/re-enabling an installed add-on.

For more details see the attached screenshot.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Attached image Screenshot.jpg
Comment on attachment 9351800 [details] [review]
[mozilla-mobile/firefox-android] Bug 1846979 - Add extensions process spawning disabled dialog  (backport #3472) (#3513)

Approved for 118.0b6, thanks.
Attachment #9351800 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Authored by Zac McKenney
https://github.com/mozilla-mobile/firefox-android/commit/1a386d0be60c1322c5dd1bd859debc66a567aca3
[releases_v118] Bug 1846979 - Add extensions process spawning disabled dialog

Authored by https://github.com/pascalchevrel
https://github.com/mozilla-mobile/firefox-android/commit/9154a7d3978662973ac106796767b9c560217665
[releases_v118] Merge pull request #3513 from mozilla-mobile/mergify/bp/releases_v118/pr-3472

Status: VERIFIED → RESOLVED
Closed: 9 months ago8 months ago
Flags: qe-verify+

Verified as Fixed. Tested on the latest Beta for Android build available from https://firefox-ci-tc.services.mozilla.com/tasks/index/mobile.v3.firefox-android.apks.fenix-beta.latest/arm64-v8a (118.0b6/Build #2015972923, 5b0ad0d350+)(GV: 118.0-20230907180212)(AS: 118) based on the STR from Comment 7.

Results:

  • Crashing the extensions process 6 times consecutively will display the UI.
  • Selecting “Try restarting add-ons” will restart the extensions process and it will be visible in about:processes
  • Selecting “Continue with add-ons disabled” will not restart the extensions process and it will no longer be listed in about:processes
  • In case “Continue with add-ons disabled” has been selected, the extensions process can be restarted by restarting the browser or by disabling/re-enabling an installed add-on.

For more details see the attached screenshot.

Status: RESOLVED → VERIFIED
Attached image screenshot beta.jpeg
Flags: qe-verify+
Blocks: 1852756
Blocks: 1852984
Blocks: 1853051
Blocks: 1853102
Blocks: 1853177
Blocks: 1857487
Assignee: nobody → zmckenney
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: