Closed Bug 1852836 Opened 10 months ago Closed 10 months ago

Sidebar goes back to loading state if closed and then re-opened

Categories

(Firefox :: Shopping, defect, P1)

defect

Tracking

()

VERIFIED FIXED
119 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox-esr115 --- unaffected
firefox117 --- unaffected
firefox118 --- unaffected
firefox119 + verified

People

(Reporter: kpatenio, Assigned: fchasen)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [fidefe-shopping])

Attachments

(2 files)

STR:

  1. Load a valid product page. Example
  2. Make sure sidebar is open and there is data
  3. Press the shopping URLbar icon to close the sidebar
  4. Re-open again using the URLbar icon

Expected: data should be visible on the sidebar after opening the sidebar
Actual: data is stuck in loading state. Refresh is needed to show analysis on sidebar

Notes:

  • Also does not work if the sidebar is hidden already when viewing a new product page and then reopening the sidebar

Regression log:

Severity: -- → S2
Keywords: regression
Priority: -- → P1
Regressed by: 1852099
Whiteboard: [fidefe-shopping]

Set release status flags based on info from the regressing bug 1852099

:fchasen, since you are the author of the regressor, bug 1852099, could you take a look?

For more information, please visit BugBot documentation.

Tracing this since it was triaged as S2

Assignee: nobody → fchasen
Status: NEW → ASSIGNED
Flags: needinfo?(fchasen)
Blocks: 1851629

Moves the product URI equality checks to isSameProduct(newURI, currentURI) method to simplify the flow and add checks for null URIs or products.

Fix the Product uninit method to set all properties to undefined.

No longer blocks: 1851843
Pushed by fchasen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d905e97b6c0e
Update shopping URI equality check r=shopping-reviewers,jhirsch
Blocks: 1852767
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 119 Branch

I have verified the fix using Nightly 119.0a1(20230915043542) on MacOS 11, Windows 10 and Ubuntu 20.04.
The sidebar is populated with the proper data in about 1s after re-opening.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: