Closed Bug 1854706 Opened 7 months ago Closed 7 months ago

When reordering columns by drag&drop, email list scrolls

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 115
defect

Tracking

(thunderbird_esr115 wontfix, thunderbird119 wontfix)

RESOLVED DUPLICATE of bug 1850893
Tracking Status
thunderbird_esr115 --- wontfix
thunderbird119 --- wontfix

People

(Reporter: top10, Assigned: aleca)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/117.0

Steps to reproduce:

Trying to reorder columns (e.g. "Subject" from first position to third, after "Spam" and "Corrspondents").

Actual results:

Email list scrolling upwards.

Expected results:

No scrolling in the email list should happen, when reordering the columns/changing the layout.

Confirmed on Mac 118.0b6

We also have a large number of scroll bug reports since 115.01, which I think may be when the last major scroll bug was fixed.

Flags: needinfo?(alessandro)
Assignee: nobody → alessandro
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(alessandro)

We're reworking our TreeView widget to make it more performant and modular, we'll fix this in the new code since this is indeed annoying but not a blocker or affecting data, it's just a bit weird.

Status: NEW → RESOLVED
Closed: 7 months ago
Duplicate of bug: 1850893
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: