Closed Bug 1855267 Opened 10 months ago Closed 10 months ago

some themes broken

Categories

(Firefox :: Theme, defect)

Firefox 120
defect

Tracking

()

RESOLVED DUPLICATE of bug 1855151

People

(Reporter: Mark12547, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/120.0

Steps to reproduce:

"Sleek Wood" theme stopped working this morning (build-id 20230926092749) and several icons (add-on jigsaw puzzle icon, the right-pointing chevron, and the menu icons) weren't visible.

On further investigation, the "Dark" and "Light" built-in themes appeared to be working, but the built-in theme "Firefox Alpenglow" would not work.

To reproduce:

After creating a new profile, I went into Menu -> Add-ons and themes -> Themes, and from the list of themes, I enabled "Firefox Alpenglow"

Actual results:

What appeared to be the "light" theme was still used.

Expected results:

I should have seen the colors of the "Firefox Alpenglow" theme in use.

Additional Information:

I ran mozregression-GUI and it stopped at:

2023-09-26T09:56:56.909000: DEBUG : Found commit message:
Bug 1848244 - Maintain parentheses in OptionalDotExpr after folding r=arai,anba

ConditionalExpr is the only case I can see where constant-folding can replace
the valid LHS of an OptionalDotExpr with another expression that isn't valid in
the AST. This can happen when the ConditionalExpr is parenthesized, and
maintaining the parentheses keeps the folded expression valid for
OptionalDotExpr.

One alternative to maintaining the parentheses is to check if folding results
in a disallowed expression (not a MemberExpression or CallExpression), and
restoring the unfolded expression if so. Wrapping in parentheses lets us keep
the folding optimization, so it seems better.

Differential Revision: https://phabricator.services.mozilla.com/D187222

2023-09-26T09:56:56.909000: DEBUG : Did not find a branch, checking all integration branches
2023-09-26T09:56:56.924000: INFO : The bisection is done.
2023-09-26T09:56:56.924000: INFO : Stopped

The Bugbug bot thinks this bug should belong to the 'Firefox::Theme' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Theme

Yep, this is an issue on Linux too.

Status: UNCONFIRMED → NEW
Ever confirmed: true

On Reddit got report that this issue also exists on Mac OS.

Likely a dupe of bug 1855151. Updating to the latest Nightly would help to confirm that.

Status: NEW → RESOLVED
Closed: 10 months ago
Duplicate of bug: 1855151
Resolution: --- → DUPLICATE

This issue appears to be resolved by resolution of Bug 1855151.

You need to log in before you can comment on or make changes to this bug.